Log in to reply

How to enable drum mags in SP?

  • Good day,

    I tried to equip drum mags on weapons with that option, but it didn't work. Additionally, I have three trainers, Menyoo, Simple Trainer, and Enhanced Native Trainer and neither can add the drum mags. I have also tried to add the drum mags within patchday8 and nothing as well. Are there any procedures? Thank you.

  • Problem with your game because there's no issues with adding drum mags in singleplayer by using a trainer whatsoever

  • @WeebGirlsrCringe
    When asking for help you should provide your game details including the version and if you have it updated.

    I'm assuming you're installing a drum mag since your dumping it in a patch?
    First question is do the vanilla drum mags work?
    Second question can you buy and install a vanilla drum mag at Ammu Nation.

    Finally, if a mod replacement, how old is the mod? If a replace mod doesn't appear it could be because there are several versions in different dlc. Do a search in OpenIV. Generally highest numbered patch works, if unsure do all.
    Also disable any weapon related scripts while troubleshooting.

  • @JohnFromGWN
    For one, I appreciate your response and not giving me that ludicrous statement "iN mY GaMe iT wOrKs". I am playing on the latest patch of Drug Wars. I had a mod replacement for the assault rifle and I've restored it to the vanilla skin, to see if I can add the drum mag to it and I cannot. To answer your first and second questions, no I cannot. Lastly, I somewhat have a weapons script the PullYaGunsOut script.

  • @WeebGirlsrCringe

    If the vanilla game doesn't allow you to add the mag, definitely do a verify integrity making sure all mods are disabled.

    Get that working first, then troubleshoot your mods. My guess is that your script is the culprit.

  • @JohnFromGWN

    Welp.... nada. This is really bizarre...

  • This is really strange, since I'm also playing on the latest version and drum mags work for me.

    Heck, I even replaced my carbine rifle with another model and the drum mag still works.

    Maybe something's wrong with "weaponcomponents.meta"?

  • @WeebGirlsrCringe The inability to see an equipment for the weapon isn't related to the model.

    You need to revert your weaponcomponents.meta file from vanilla. or if you can do it, compare the 2 with Notepad++ and check the weapon you are trying to add Drum Mag.

    If you don't see Drum Mag for anything, then possibly a weapon mod you installed modified the file and removed the attachment. Regardless of it, restoring this file from vanilla will fix your issue.

  • @MissySnowie

    He said his vanilla doesn't work after a verify integrity...so SOL.

    @JohnFromGWN said in How to enable drum mags in SP?:


    If the vanilla game doesn't allow you to add the mag, definitely do a verify integrity making sure all mods are disabled.

  • This post is deleted!

  • @JohnFromGWN He said he restored it to vanilla skin. So I am assuming by skin, he means the weapon model.

    He didn't try it with full vanilla game.

    @WeebGirlsrCringe said in How to enable drum mags in SP?:

    I had a mod replacement for the assault rifle and I've restored it to the vanilla skin,

  • @MissySnowie

    Will do it right now. What specific path do I need to check?

  • @WeebGirlsrCringe said in How to enable drum mags in SP?:

    Will do it right now. What specific path do I need to check?

    When someone suggests a verify integrity to restore a game to its vanilla state, it's to rule out all issues caused by mods.

    By not doing it, you're not helping yourself, you're just confusing those trying to help.

  • @JohnFromGWN Sorry for the extremely late response my bro. I have verified the game files and nothing occurred. Here is where things get interesting... When I removed the mods folder from the directory... I can put drum mags on... The mods folder is the issue. I do have weapon mods. Mostly replacement which is most likely the issue.

  • @WeebGirlsrCringe
    Good. Now you need to identify the problematic one, possibly a conflict between mods. I'm not into weapon mods but from experience I've had conflicts between peds, twice, and ofc vehicles can have modkit conflicts. Possibly something similar with weapons.

    By renaming or removing mods you've identified where the problem lies. Next step is which mod or mods. This process of systematically eliminating variables is foolproof but takes time. In worst case scenarios it could be conflicts between mods and scripts etc, but the process still applies, just takes longer.


    Alright so TDLR, When I first started modding my dumbass was just adding mods with no care. I have tried to install a mod called "XM25". This was posted back in 2016. I have compared the weaponcomponents files and the KB was off. What I did was, I replaced the mods folder weapon components file with the vanilla file and I booted up the game and BANG I CAN FINALLY USE DRUM MAGSSS. LESSSSSS GOOOOO!

  • @WeebGirlsrCringe that's great, good detective work

  • @WeebGirlsrCringe It took that long?

  • @-EcLiPsE-

    I think even the most difficult issues shouldn't take more than 15 - 20 minutes to solve.

    And the worst absolute solution would be to restart from scratch and reinstall all mods..maybe 1.5 hour tops.

    Unfortunately the proven process of elimination is perceived as taking too much time so gamers take shortcuts or watch terrible videos on youtube. Of course the most common "fix" is to reinstall multiple times. First time is just a tryout, second time you gain experience, and by the 4th or 5th reinstall, it should definitely fix all issues...because computers do everything randomly...you just can trust them with a game or mod installation.

    I honestly feel sorry for everyone struggling to fix game issues when it is really just a question of following an incredibly simple process. Especially the ones who write "I installed everything correctly, got the best gameconfig, and reinstalled 30 times".

  • @-EcLiPsE- In my defense, I haven't touched my computer in a while due to work. When I got home and hopped on the computer. I wanted to see what was the issue and fix it once and for all. I went through the many mods I have installed to see the issue. It cannot be addon cars or peds. Then it hit me, the mod weapon I tried to install https://www.gta5-mods.com/weapons/xm25-cdte-add-on. I went to compare both weapon component files in the mods folder and update they were off. I just copied that file and dropped it in the mods folder and boom problem is solved.

  • @JohnFromGWN I tried using youtube and did not work so I just fixed it myself. I don't install crazy mods. Just add on peds and cars, and Replace mods. I appreciate you guys. :)

  • @WeebGirlsrCringe I was just writing in general...from the thousands of posts I've seen here requesting help.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.