Log in to reply

enchanced native trainer

  • Hey guys by some reason I cant control the trainer with my keyboard but always could with my controller. By mistake I disabled controller use in the trainer and now I can use the trainer at all. I have tried other trainers but same thing. Is there anything I can do to reset the trainer? I even tried deleting all the files but every time I re download it from steam the mods file appear again.. Please Help don't know what to do.

  • @rorro721 For ENT, there's a folder in either appdata\local or My Documents, I can't remember which. I think the settings are in there.

    Edit: It's in Users[Your Name]\AppData\Roaming\GTAV Enhanced Native Trainer Beware though, that file contains all the settings as far as I know, for saved cars and other things. Back it up before you delete that...

    Actually, just looking in the ENT download, have you got the ent-config.xml in your game folder? If not, try editing that and then copying it into your game folder before you delete anything.

    Double-Edit: Default Controller config for that is Right-Shoulder + Y

  • @LeeC2202 As far as I can see the ent-config.xml is to assign different buttons from what it says they are assigned but still do not work in game. And I need to find how to stop the controller from being disabled.

  • @rorro721 Right at the bottom is all the controller functions, do they still have values set in them in yours? For instance, I see this in mine.

    <controller function="toggle_main_menu">
      <button value="R_SHOULDER"/>
      <button value="BUTTON_Y"/>

    Is that section there in yours like that?

    I've also found a setting in the ent.db file (that is in the appdata folder). The setting is called featureControllerIgnoreInTrainer which might be the setting that needs resetting. If so, there are two ways to do it.

    Download a programme called DB Browser for SQLite from here https://github.com/sqlitebrowser/sqlitebrowser/releases

    With that you can view and edit the ent.db file and change that setting.

    Or you can send me your setting file and I can change it for you. (it's 4:05 am here now though, so I won't be able to do that until later)

    If you want to make the change yourself (it's easy to do), install that programme, Copy the ent.db file to your desktop while you edit it. Run the programme and choose Open Database from the top of the window.

    Click the Browse Data tab and where it says Table, click the down arrow and choose the option that says ENT_FE..LEMENT, that will open the ENT_FEATURE_ENABLEMENT section.

    Scroll down until you find the setting I showed above in red and if it is set to 1, click the number 1 to highlight that cell, right-click to edit it and change it to 0. Hit Return and then choose File > Write Changes

    Exit the programme and copy that file back into the folder it came from in your AppData folder. See if that resets your controller.

    It is possible though that the setting is telling the trainer to ignore the controller in the game while you are in the trainer, so that pressing controller buttons doesn't trigger in-game actions.

  • ok perfect! got it to work! @LeeC2202 just have one more question if you don't mind.. The mods fold is giving me a lot of issue, is there anyway to get rid of it and start all over again? the trainer cant find any cars or anything now, I know its giving me a lot of issues but slowly fixing them

    thanks in advance!

  • @rorro721 Yeah, what I would do, is rename the existing one, just so you have a copy of all the data.

    Create a new folder called mods. Create the update folder inside that and copy the update.rpf file from the main game's update folder into it. Create an x64 folder in there and then the dlcpacks folder inside that.

    That will give you a completely fresh mods folder, with a copy of the default update.rpf file. You can then rebuild your mods into that. When you are happy with that, just delete the old (renamed) mods folder.

  • @LeeC2202 yea thanks! just did that but still the trainer doesn't seem to find any of the car mods I added. even installed the crash update for car add-ons but nothing.. and can only add one mod at the time without the game crashing.. its so fun to play but giving me way to much trouble :(

  • @rorro721 Have you installed a new gameconfig file? Is that what you mean by the crash update?

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.