Log in to reply
 

How to fix tuning parts and lights not working on addons or making your own car packs


  • MODERATOR

    @negnoodles
    modkit ID> the number the modkit refers too in carvariations.meta. Always accompanied with the name of the modkit aswell;
    <Lights> ID > the number for the lights in carvariations.meta, must be in some carcols.meta in a dlc that is loaded by the game;

    When the tuning AND lights won't work then the modkit_ID has become 'corrupt' for lack of a better word.
    You can't keep finding free modkit_ID numbers sadly.

    I've foudn out that numbers that worked before suddenly stop working (so no more tuning etc) when you add more cars to a dlc (of even a different dlc). Wether that has to do with memory issues or bad coding is beyond me.

    See my post and search activities, alsmost crusade in !@#$%$%#@@ Modkit ID's



  • Whta about a mod without a <lights> section? I tried adding a new car earlier without a <lights> section data and realized the car didn't have tuning options right off the bat. I meant it as in only lights, plate and wheels appear in LSC and nothing else.

    Also, thanks for the reply. I guess it's the only way to accept this all now. I still can't wrap my head around the fact that I can't have unlimited dlcpacks like last year, and now I have to create my own and risk running into having tuning and lights corrupted. Sigh lol.

    Does anyone here happen to have a good dlcpack that is stable + consists of maybe the more popular cars on the site?


  • MODERATOR

    @ReNNie No, I just copied it 1 time for each DLC pack (sometimes I hadn't to copy it lol) and then used the same <lightsettings> value for all the cars.



  • This post is deleted!


  • This post is deleted!


  • Won't make it sense to add all R* dlc's into one root RPF? So no external loading that reach the limt?

    We got a x64c RPF and so on. Why not try to install it like tall70 Yacht mod?


  • MODERATOR

    Could be done, but it's a pain-in-the-butt to make all the referrals in content.xml (also in update.rpf) etc work correctly. But it surely is a good plan!

    I've also deleted obsolete car models in previous patchday rpf's which frees up model space for add-ons. It's just plain stupid to load all those yft's when they're never called upon anymore by the game engine.



  • @ReNNie are you talking about deleting car models that are in patchday1 or patchday2 folders then just keeping the newest ones that are in patchday10 or patchday12 etc? Because that makes sense to clear up space and you could do the same thing with weapons as well.


  • MODERATOR

    yes, that is what I did. After that I could import way more cars in addon's



  • @ReNNie thats a good idea, also some people delete the tuning parts from x64i.rpf of cars they dont drive.


  • MODERATOR

    okay, I'll look into that too. And remember, first make backups of the rpf and then carefully check which are there in later rpf's



  • @ReNNie So how does that work? Do you have to match the cars one by one to identify the duplicates? Or do you just delete them all and don't care about the ones that aren't duplicates. Cus some cars, like vans and those unpopular "normal" cars aren't duplicated as often as some more "popular" ones.

    @Willief23 Thanks so much. I plan to just redo this all and see if it yields better results. I have to ask though, I tried adding carcols into carcols.ymt (I followed your steps, copying kits/lights into their sections) but it still instantly crashed my game. It's really weird, have you ever run into this? Also do you have to update the carcols.ymt file everytime you add more cars? Also, let's say you have 3 DLC packs, do you just copy all 3 DLC packs' carcol data into the single ymt file?


  • MODERATOR

    @negnoodles .. yep open the last pathday rpf and also the previous ones and start deleting the duplicate ones



  • This post is deleted!


  • @Willief23 I'm following exactly your steps yet the game still crashes no matter what. I even tried using the auto installation for the carcols link you provided and as long as I add anythjing from my carcols to the carcols.ymt, the game will definitely crash. Btw I followed your steps 100%, meaning I did exactly what you listed, <kits> into <kits>, <lights> into <lights> and replaced in the mods folder yet I still crash at loading screen.



  • This post is deleted!


  • @Willief23 Hey, okay thanks Ill do that. I never knew spacing was even something worth considering lol, I just imagined that as long as it's on the right line then its fine



  • How do you solve this problem with lights in the model itself???

    This mod obviously has lights built in
    https://www.gta5-mods.com/vehicles/porsche-911-gt3-2004

    But when you install it ingame the lights are blank



  • This post is deleted!


  • @Willief23 The car is not an addon its a replace for the Rapid GT, but I renamed it to replace the Comet.
    What do I do in this case??



  • This post is deleted!


  • @Willief23
    Tried it with no luck



  • This post is deleted!


  • @Willief23 Its weird because in the other two videos on the mod page the lights are working fine. In all the author's pics the lights are working fine, but when a couple of us put it in game they are blank.
    So they def work, even the author has no clue why they don't work for others
    i even wrecked the front of one ingame and sure enough the damaged lights will show

    alt text



  • This post is deleted!

Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.