Log in to reply

Help with .NET!

  • I have been trying to install mods like this and this and they both require nativeUI and ScriptHookVDotNet. Using NativeUI 1.7 and SHVDN 2.9.4 I cannot get these to work, well, not really.

    The first time I loaded up the game with said mods installed, I was able to walk around for 10 seconds until the game crashed (it even loaded the mods fine!).
    Now I can't get so far.

    (So you know, with these mods uninstalled the game works fine along with my other mods which are not .NET)

    I believe the problem lies with either SHVDN or NativeUI... probably the former...

    Can someone help!


  • Some more info:

    The game loads fine with SHVDN just sitting in the directory, but as soon as I add even just NativeUI, the game crashes.

    So it's either a problem with NativeUI, a compatability issue between the two, or a problem with SCVDN not being able to load .NET stuff.

  • Check ScriptHookVDotNet's log file(s).

  • @edwardlb21 Make sure you have the latest version of ScriptHookVDotNet, which is still called 2.9.4

    If the file you are using is called ScriptHookVDotNet2.asi, you have a version that causes NativeUI to crash. If so, get the latest version which will be called ScriptHookVDotNet.asi and will work fine with NativeUI.

  • @LeeC2202 I do have the latest version and not the '2' version.

  • @MAFINS No errors in SHVDN's log... :/

    Here's the R* launcher.log from Documents though:

    [2017-01-07 17:31:18.369] [DISPLAY] Using DPI 96
    [2017-01-07 17:31:18.684] [DISPLAY] File version 10000:3b00002 (for C:\Program Files\Rockstar Games\Grand Theft Auto V\GTA5.exe)
    [2017-01-07 17:31:23.025] [DISPLAY] File version 10002:10000 (for C:\Program Files\Rockstar Games\Social Club\socialclub.dll)
    [2017-01-07 17:31:23.283] [DISPLAY] File version 10000:3b00002 (for C:\Program Files\Rockstar Games\Grand Theft Auto V\GTAVLauncher.exe)
    [2017-01-07 17:31:23.342] [DISPLAY] Version:|1.0.944.2||1.0.944.2|FFP
    [2017-01-07 17:31:23.936] [DISPLAY] OS version: Major: 6, Minor: 2, Build: 9200, Platform: 2
    [2017-01-07 17:31:24.181] [DISPLAY] File version 10000:3 (for C:\Program Files\Rockstar Games\Grand Theft Auto V\PlayGTAV.exe)
    [2017-01-07 17:31:24.992] [DISPLAY] File version 10000:3b00002 (for C:\Program Files\Rockstar Games\Grand Theft Auto V\GTA5.exe)
    [2017-01-07 17:31:25.232] [DISPLAY] Opened options file.
    [2017-01-07 17:31:25.527] [DISPLAY] File version 10002:10000 (for C:\Program Files\Rockstar Games\Social Club\socialclub.dll)
    [2017-01-07 17:31:25.729] [DISPLAY] Social Club initializing...
    [2017-01-07 17:31:27.416] [DISPLAY] Attempting to create device...
    [2017-01-07 17:31:27.436] [DISPLAY] Attempting to initialise DX9 COM object...
    [2017-01-07 17:31:27.497] [DISPLAY] Window size: 690 x 496
    [2017-01-07 17:31:27.632] [DISPLAY] Successfully created DX Device!
    [2017-01-07 17:31:32.119] [DISPLAY] Geo: GB
    [2017-01-07 17:31:44.031] [DISPLAY] File version 10000:3b00002 (for C:\Program Files\Rockstar Games\Grand Theft Auto V\GTA5.exe)
    [2017-01-07 17:31:58.702] [DISPLAY] In-place download is up-to-date.
    [2017-01-07 17:31:59.186] [DISPLAY] Launching game...
    [2017-01-07 17:31:59.204] [DISPLAY] (path: C:\Program Files\Rockstar Games\Grand Theft Auto V\GTA5.exe cmdline: "C:\Program Files\Rockstar Games\Grand Theft Auto V\GTA5.exe")
    [2017-01-07 17:34:40.773] [ ERROR ] HRESULT failed when doing m_device->Present(NULL, NULL, NULL, NULL) : 88760868
    [2017-01-07 17:34:40.786] [WARNING] Device lost.
    [2017-01-07 17:34:40.787] [WARNING] Resetting device...
    [2017-01-07 17:34:41.547] [WARNING] Reset failed with D3DERR_DEVICELOST.
    [2017-01-07 17:34:56.006] [WARNING] Resetting device...
    [2017-01-07 17:34:56.338] [DISPLAY] Reset succeeded.
    [2017-01-07 17:35:07.926] [WARNING] Device lost.
    [2017-01-07 17:35:09.713] [DISPLAY] Reset succeeded.
    [2017-01-07 17:35:11.416] [DISPLAY] Reset succeeded.
    [2017-01-07 17:35:26.493] [ ERROR ] HRESULT failed when doing m_device->Present(NULL, NULL, NULL, NULL) : 88760868
    [2017-01-07 17:35:26.499] [WARNING] Device lost.
    [2017-01-07 17:35:26.500] [WARNING] Resetting device...
    [2017-01-07 17:35:27.145] [WARNING] Reset failed with D3DERR_DEVICELOST.
    [2017-01-07 17:49:51.064] [ ERROR ] GameComm: ReadFile failed.
    [2017-01-07 17:49:51.456] [WARNING] Resetting device...
    [2017-01-07 17:49:51.582] [DISPLAY] Reset succeeded.
    [2017-01-07 17:49:59.633] [DISPLAY] Game exited with code 0x0
    [2017-01-07 17:49:59.698] [DISPLAY] Reset succeeded.
    [2017-01-07 17:50:02.129] [DISPLAY] Uninitializing.

  • @edwardlb21 What happens if you rename your mods folder to something else? That's assuming you have one of course, I can't see anything mentioned either way.

  • @LeeC2202 Yup I got one with car and 4k map mods inside (they are not the issue, trust me, game works fine with these installed). Will try this tomorrow and update on progress.

  • @edwardlb21 No worries, you'll have to forgive me if some of the questions I ask seem obvious... I have to try and build a picture of what you have got set up, to try and work out where the problem might lie. Diagnosing at a distance can be tricky. :slight_smile:

  • @LeeC2202 Sure, no I understand!

    What I don't understand is all this 'device lost' gibberish above, what could that possibly mean?

  • @edwardlb21 My log is full of them, I think it happens if you do something like Alt+Tab. Because I write script mods, I am constantly Alt-Tabbing out of the game.

  • @LeeC2202 I wish it was, but I don't always alt+tab out and this error IS always there... I think the real error is "GameComm: ReadFile failed." Am I correct?

  • @edwardlb21 I have that error as well... I'd post my log but it's 109 lines long, so a bit long for a forum post. Actually, here's a link to it on my Google Drive, this should give you an idea of what's normal in that file. https://drive.google.com/file/d/0B7LFvItVrwd0dXhfOVNPV2hucVE/view?usp=sharing

  • @LeeC2202 Holy carp! Is that a crashed log or just normal?

  • @edwardlb21 That's normal. :)

  • @LeeC2202 Wow.

    So what do you think the error might be? I'll try the mods thing tomorrow, but it's really weird.

    I checked windows event viewer too: Faulting module path: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll

  • @edwardlb21 Have you got the Visual C++ 2013 sp1 installed and .Net 4.5.2 or higher?

  • @LeeC2202 .Net 4.6.2 installed and.... do these count?

  • @edwardlb21 Yeah, that all looks okay. Are you using Windows 10?

  • Yup, Insider Preview.

    This might be handy if I can get access: https://support.microsoft.com/en-gb/kb/2640103

  • @edwardlb21 I asked that because I run a dual-boot system with Windows 7 as my development OS and Windows 10 as a disposable test-bed. I can try those two mods in my WIn10 install but I won't be able to do that until later... currently in Win7 fighting with timestamped files.

  • @LeeC2202 That would be awesome if you could.

    I keep contacting support to get access to the hotfix but they keep sending me the wrong files...

  • @LeeC2202 Got the hotfix, was blocked by system as I already had something similar installed

  • @edwardlb21 Well I tried both of those mods and all seemed to be fine... completed a single Simeone mission, and as I normally start with Trevor in the desert I had to go all the way across the map to get there and then complete the mission, so it was running for quite a while.

    I've never actually seen those 2 mods in action before, they're kinda cool so I might leave them in my Win10 version.

  • @LeeC2202 Which is exactly why I want them :(

    What do you suggest from here? Is there a way to absolutely get these working (a long, hard way)?

    Are we talking along the lines of a clean install? Of GTA AND Windows?

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.