Log in to reply

Help with .NET!

  • Could you post a screen clipping of your .NETs installed in programs and features and C++ packs too? So I could try an exactly replicate them?

  • @edwardlb21 You'll have to give me a while to do that, I'm back in Windows 7 again. My Windows 10 install is isolated from the net because I just don't trust it. So to post on here, I have to be in Windows 7. It's not just isolated from within Windows either, I have it completely blocked in my Router so that it doesn't bypass any HOSTS file or anything.

    I know that might seem kinda paranoid but when you have critical development files, you are by nature very wary of anything that is allegedly scanning and transmitting data about what it finds. I have all sorts of confidential documents on my drives and I have to protect them. I also don't like how it's trying to make connections all the time, so I just locked it down. I will check later though.

  • @LeeC2202 That would be a big help. I might try a less destructive method first: clear all .NETs and all C++ packages from system and then just install the most recent version of both. Can I do that, or do some programs require older versions?

  • @edwardlb21 Some programmes require older versions, it depends which versions they were built against. Whilst .NET is backward compatible, the C++ redist packages are not sadly. So you need to have them all installed or other programmes will fall over.

    You do only need the x64 version of 12.0.30501 though.

  • @LeeC2202 I also meant to ask, what exact version of Win10 are you running?

    (^^So I can just install most recent version of .NET but for C++ I probably need to leave those alone?)

  • @edwardlb21 I'm running the Home version... it was an upgrade of a Windows 7 Home Premium license.

  • @LeeC2202 Sorry I meant public, or insider (what version number?)

  • @edwardlb21 Ah, it's just a standard public version.

  • @LeeC2202 Okay. So my insider preview builds might be breaking something potentially.

    (Urghh I hate waiting for 2 mins to post each time xD)

  • @edwardlb21 Don't worry, I'm never in a rush and I won't disappear if your answers take time to appear. I have infinite time to spare...

  • @LeeC2202 I'm grateful that you actually made an effort to assist me unlike the rest of this community

    Whilst I wait for your screenshot, I will update this thread once I do a clean install of .NET frameworks.

  • Okay... XML was doing my head in, so I decided to get this screenshot... I suspect this might get the same response as my launcher log, it might not be what you were expecting to see. :slight_smile:

    Edit: I have just looked back at your screenshot and noticed VS2015 Express installed, so it's probably exactly what you were expecting to see. :D


  • @LeeC2202 Lol what a mess...

    I cleared out all versions of .NET framework anyway, nothing shows up in Programs and Features but that's because 4.6.2 is inbuilt into Win10.

    I also uninstalled VS Express and repalced with VS Commnuity because why not, it was broken.

    What else can I try?

    EDIT: Lol installing VS Community basically replaced all the .NETs I uninstalled, oh well, hopefully it repaired a few in the process...

  • @LeeC2202 Thought I would include this for good measure:

  • @edwardlb21 Wow, there's a lot of errors in that list.. I have to wonder if there isn't a more fundamental problem in your system, that is causing this level of failures. If there is, then it will make fixing GTAV almost impossible.

  • @LeeC2202 It's probably an Insider Preview thing, this amount of errors is normal for preview software. None of it affects day-to-day usage however.

  • @edwardlb21 Ah, okay... I just didn't remember seeing all that kind of thing when I was in the Windows 10 insider programme, hence my concerns.

  • @LeeC2202 Oh really? I wonder how I could minimise these errors?

  • @edwardlb21 I must confess, I do get similar errors in my Win7 occasionally, so maybe that just looks worse because they're all lumped together. In fact, checking my events, I get the 10016 and the 7034 error, one of which I know is caused by my actions... so maybe I am over-thinking things. I'm not used to being online this early in the day, maybe I'm suffering from "should still be asleep" syndrome. :D

    I take it that if you run a completely clean, unmodded GTAV, you don't get that application error?

  • @LeeC2202

    • Game works vanilla
    • Game works with .rpf mods
    • Game works with .asi mods
    • Game crashes with .NET mods

  • @edwardlb21 I know this might sound counter-intuitive but have you tried using an older ScriptHookVDotNet? Or does it happen with every version?

  • @LeeC2202 I will try that now. Also here's a messed-up launcher.log segment (check out that crazy error code):
    [2017-01-09 12:03:38.716] [ ERROR ] GameComm: ReadFile failed.
    [2017-01-09 12:03:39.125] [DISPLAY] Game exited with code 0xc00000fd
    [2017-01-09 12:03:39.126] [ ERROR ] Unable to stat out-file!
    [2017-01-09 12:03:39.137] [ ERROR ] ************************************************************************
    [2017-01-09 12:03:39.137] [ ERROR ] * Setting error condition
    [2017-01-09 12:03:39.139] [ ERROR ] * Category: 1 (ERROR_CATEGORY_LAUNCHER)
    [2017-01-09 12:03:39.141] [ ERROR ] * Code: 107 (LAUNCHER_ERR_GAME_CRASHED)
    [2017-01-09 12:03:39.141] [ ERROR ] * Extra:
    [2017-01-09 12:03:39.141] [ ERROR ] * Localised: Launcher error. Code: 107
    [2017-01-09 12:03:39.141] [ ERROR ] ************************************************************************
    [2017-01-09 12:03:39.153] [ ERROR ] Unable to read out-file!
    [2017-01-09 12:03:39.164] [ ERROR ] ************************************************************************
    [2017-01-09 12:03:39.164] [ ERROR ] * Setting error condition
    [2017-01-09 12:03:39.165] [ ERROR ] * Category: 5 (ERROR_CATEGORY_EXIT_CODE)
    [2017-01-09 12:03:39.166] [ ERROR ] * Code: -1073741571 (c00000fd)
    [2017-01-09 12:03:39.167] [ ERROR ] * Extra:
    [2017-01-09 12:03:39.167] [ ERROR ] * Localised: Grand Theft Auto V exited unexpectedly.

  • @edwardlb21 I tried to do a search for that, it seem R* like their long error codes, plenty of them about and causes seem to range from graphics cards to audio card drivers. This could take a while to fix yet...

  • @LeeC2202 Tried 2.9.4, 2.9.3 and 2.8. No joy.

  • @LeeC2202 did you say earlier that my mods folder may conflict with .NET? I forgot to try that... I'll do it now.

    EDIT: Removed ALL other mods apart from SHV, SHVDN and Tow Jobs Files and still crashes

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.