Log in to reply
 

Can not recoginze the correct way of open door in game.



  • Hi Everyone~
    I'm working on the Flatbed truck recently.
    The target is make flatbed can be moved, rorate up and down, move forward and backward.

    this means the flatbed needs two animation.
    Since we can only give 1 animation to 1 component, so I made flatbed in 2 parts.

    here is the list:

    scoop
    -boot
    --boot [col]
    -scoop [col]

    First level is scoop, second level is boot.

    Scoop component can be control by numpad 8 & 5, it take care of "Rorate up and down" part.
    Scoop is from the Bulldozer vehicle.

    Boot can be control by trainer, open and close. But, in this case, I changed the data of user define.
    I changed RotX to SlideZ, and Flags is ABE. RotY and RotZ have been deleted, of cause.
    Now, in the game, the boot will slide forward and backward, when I control it by Trainer.

    Until now, everything seems ok.

    But, the problem is come.
    It is very strange, that when I open and close boot second time, the position of flatbed will goes wrong.
    Only the first time the position and the slide animation is right. After that, it has mistake.
    the result you can see in the video:

    --
    I tried many times and solutions, then I found a way to solve it.
    If I delete the collistion file of boot, then the animation will be ok.
    the new list is like this:

    scoop
    -boot
    -scoop [col]

    although the slide animation is kind of strange, but anyway, it works.
    the result you can see in upper video.

    The problem seems solved, but as you know, I removed collistion file of boot, then player can not stand on the flatbed.
    This is not ok.
    I need player can stand on the flatbed, so the vechiles can drive on to it.
    few moments later, I figured out a way to solve this problem, at least, I thought it works, at that time.
    I added extra_1 under the boot.
    The 3rd list is like this:

    scoop
    -boot
    --extra_1
    ---extra_1 [col]
    -scoop [col]

    And of cause, boot still has no collision, but extra_1 has collision file.
    I run the test in the game again, the result is sad.
    Scoop works OK,
    Boot can slide forward and backward.
    But, the extra_1 didn't move follow boot.
    It seems like the relastionship between boot and extra_1 is gone.
    the result you can see in upper video.

    --
    Well, then, I tried to put collistion file back to boot. Although I know, the animation will be wrong. I just want check the extra_1 can be moved or not.
    the 4th list is like this:

    scoop
    -boot
    --extra_1
    ---extra_1 [col]
    --boot [col]
    -scoop [col]

    And the result is kind of good. the extra_1 moved! it can move follow the boot.
    But still, the animation of boot is bad.
    the result you can see in upper video.


    Untill now, this problem drives me crazy, I have no idea how to fix it.

    BTW, I also tried use towarm to replace scoop.
    The 5th list is like this:

    towarm
    -tow_mount_a
    -tow_mount_b
    -boot
    --extra_1
    ---extra_1 [col]
    --boot [col]
    -towarm [col]

    The result is same as I use scoop, the boot can slide, the extra_1 also can move follow the boot.
    But the position of boot will goes wrong after 1st time move.
    the result you can see in upper video.


    Does anyone has interest on this problem? and if you have solution for me will be better.
    Thanks.


  • TRANSLATOR

    bump


  • TRANSLATOR

    bump


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.