Log in to reply

[SOLVED] Weapon Mods do not work - but other mods do!

  • Hey folks,

    I am using OpenIV 2.8 with mods folder and activated ASI-Loader and OpenIV-ASI.
    I added multiple different mods to my game like the coloured weapon wheel, coloured 4K Map, Refined Weapons and Gameplay and a lot of different cars (replace and addon method). EVERYTHING WORKS FINE! But if I want to install any weapon mod, like the SCAR-H, HK416, Glock, whatever, it never works! Only the standard vanilla weapon skins are shown. It doesn't work neither if I try to buy them via ammunation nor if I add all weapons via a trainer. Even if I modify the original game files (without using the mods folder), it doesn't work :-(.

    Is there someone who can help me with that problem? Thanks a lot in advance.


  • a lot of weapon install instructions are outdated due to R* updates unfortunately, however just about all of them can still be used if placed in the update/x64/dlcpacks/patchday8ng folder instead of wherever it tells you. keep in mind this directory may change over time once R* releases another update that applies a new weapons.rpf set over the old ones, but for now that one should work for just about any weapon you'd need

    be sure to use a mods folder and such though otherwise you may mess some shit up if you replace the original files without backups

  • Hey Zippo!

    Thanks a lot! That solved my problem! Amazing! It really bothered me playing with the vanilla fantasy weapons. Again, thank you for your help!

    P.S: I am only using the mods folder. Changing the original files was just a try to find out if that works.

    Kind regards

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.