Log in to reply

dinput8.dll makes GTAV crash during loading

  • Please help. After GTA V updated(auto update on steam). I found out dinput8.dll makes game crash during loading step. When I delete it, I can enter the game normally.

    Please advice! Want to spawn my car!


  • Try reinstalling dinput with a fresh Download.

  • I have done it several times even have tried different versions.

  • Have you updated scripthook

  • @ronsars Rename your mods folder and try loading the game. dinput8.dll is an asi loader and OpenIV needs that to use your mods folder (textures, cars, peds etc...), so it could be a faulty mod that is causing the problem.

  • same problem using redux, how do i fix this? i only want to use a trainer and it will always crash, but if i remove the trainer it works fine

  • @Nelroma This thread is not about Redux, please create a thread about your own problem so that people can answer it directly.

  • I know what it is, it is not dinput, it is something wrong with your mods folder. Happened a few times to me. What you want to do is keep dinput in the main folder but take out the mods folder out of the main Grand Theft Auto V folder. If it doesn't crash, Then put the mods folder back in, but remove the subfolders in the mods folder, one by one, and play it to see which one crashes the game. Once you find the corrupted folder/ mod, delete that folder and re-download the mods that you threw away. Problem should be fixed.

  • Look at your OpenIV.log sometimes near the last thing loaded by the game there is the path of the corrupted archive
    you ll maybe remember a file you replaced before.. But I don't know if it will really works, I am not sure at all it can help you ,
    most of time , I just look at all the mods I downloaded see if I am missing something (always look at read me/documentation included, even if you think it's okay) and take a quick look at the mod topic or page to see if somebody notice a similar issue ..
    Also you can try opening all the .rpf archives where you installed mods , OpenIV may tell if it's corrupted , I noticed that the last time with gtxd.rpf
    Good luck to find your issue, it's not everyday easy

  • Banned

    you have to rename it I bet you're using enb reshaders

  • Fam, this is the last time I will tell you. It is not dinput, it is your mods folder. Dinput simply makes your mods folder work. Once gta updates, the mods folder will most likely be out of date, you need to go in there on openiv, update it, and check for corrupted mods. (:

  • @TheLoneWolf293 what if I don't have any mods I instal the game and wanted simple trainer I followed all the instructions precisely and still it crashes what do I do now? I also took out dinput and it worked just no trainer.

  • @TheLoneWolf293 nope, i have the same issue. once i remove dinput8.dll, the ragehook work fine, but the mods are not showing because it need dinput 8 to be able to work. my mods folder have no issues because my game work without ragehook...

  • my gtav crashes because of dinput8.dll

  • @tsglava1 you will need to update your dinput8.dill

  • @RickGrimes2017 Question would you know where the new dinput is?

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.