Log in to reply
 

Map Builder install screwup



  • It seems OpenIV has really screwed up my GTA V Map Builder install. The author of the latter wrote:

    The package installer asks you where to install the mod and you should have clicked "mods" folder.

    Yeah, except OpenIV asks no such thing. You must choose the GTA V game folder, or it will not allow you to continue. And then it has a single Install button that screws up the install. :(

    So, I tried it manually:

    -Open GTA V File Location (Directory)
    -Copy "update" Folder To "mods" Folder

    And, guess what, there's no update folder to copy to anywhere.

    So, how do I get this thing installed properly?!


  • MODERATOR

    @meimeiriver Do you mean Redux?



  • No, just the regular STEAM install of GTA V (Am trying to install Franklin's New Garage mod).



  • @meimeiriver In the main GTAV directory, there are three folders by default, ReadMe, update and x64. If you don't have all of those, you don't have a complete installation. Which of those folders exist inside your main GTAV directory?



  • @LeeC2202 Okay, yes, I see what the idea is now. :) Thx. I thought he meant '-Copy "update" Folder [from the Map Builder unpack folder] To "mods" Folder'.

    Still don't understand why OpenIV doesn't offer a 'put in mods folder' option, but manual install it is then. :) Thx again.



  • @meimeiriver I think you need to have the mods folder in there first before OpenIV will use it. If you need help setting it up, just post back and we can help you with that.



  • A mods folder right under the main game folder, you mean? Cuz i had already created that first too, then closed and retried OpenIV, but that made no difference.



  • @meimeiriver Inside the mods folder, you need the update folder and you need to copy update.rpf from Program Files\Rockstar Games\Grand Theft Auto V\update into mods\update

    So in the end you have Program Files\Rockstar Games\Grand Theft Auto V\mods\update\update.rpf

    I think OpenIV needs at least that much to recognise the mods folder.



  • @LeeC2202 Ah! :) So that's what I missed. Will try that.

    P.S. You ppl are very friendly! :) On the STEAM GTA V forum people are so rude! This is quite a delight!



  • @meimeiriver That's because some of us are old people... we know better than to be rude to people who need help. :D



  • @LeeC2202 I'm insulted, LOL. And I'm sure a lot of others are too. :stuck_out_tongue:



  • @Akila_Reigns Compared to the Steam crowd, you are an old person. :D

    I sometimes find it hard to believe anyone there is over the age of 12 at times, it's a horrible place to try and get help.



  • @LeeC2202 Thx for all the help. :) This time it installed properly and gave me the 'mods' folder option. Guess the tool assumes you've already installed mods before. My bad.

    Franklin's New Garage mod isn't showing up, though (though I did see the game briefly mention it was loading the 2 garage files). Is it really supposed to be behind Franklin's home?! I mean, his place is a dump!





  • @LeeC2202 Oops, looks I got an older one older garage?

    Guess I should go and try to install the new one first! Thanks again!

    Need me some storage space! :) Kinda strange the game offers so few official save-slots to begin with, but I digress.



  • @meimeiriver There are a few of them, so I wasn't sure which one you were using. From what I can see though, they don't install as OIV packages, they're just map editor maps, so I am a little confused. :confused:

    Doh! Sorry... it's map builder that's causing the problem, not the garages. :blush: *note to self, learn to read* :(



  • @LeeC2202 Sadly, can't get this garage to work. :( One of the dependencies, Object Spawn Unlocker 1.1, reportedly no longer works. Sad. All I wanted was some nice extra vehicle space.



  • @meimeiriver I have Object Spawn Unlocker and found that version 1.1 wouldn't work, but 1.0 did. There should be two versions in the download, try the older version. That was on a mod only a couple of weeks back where I tried it as well, so that's with the latest game version.



  • @LeeC2202 Ah. :) Thank you! I just created a separate topic for it, LOL (as this topic was supposed to be about the map editor). If your solution works (I'll find out in a few minutes), I will just delete the other topic.



  • @LeeC2202 Sadly, it made no difference. :( To be clear, those button should appear right behind Franklin's house, right? (like in his backyard?)



  • @meimeiriver I'm not sure what you mean by buttons appearing... I've never used one of those garage mods, I presumed it just made a big building appear when it loaded the map. So from what I understood, you should have the map file in a folder called AutoloadMaps, so when the game runs, Map Editor loads the map straight away.

    Do you have Map Editor installed as well as Map Builder?



  • @LeeC2202 Well, the author said:

    If you installed correctly the SPG Mod and you followed the instructions you will see two icons behind Franklin's house, one for each floor.

    No icons to be found.

    The thing is (which is why I asked), that Franklin's home is a hovel. He basically lives in '"sh*tty part town' (think South Park), so that garage scene couldn't possibly be 'physically' crafted onto the neighborhood, as it were.

    And yes, I installed Map Editor as well as Map Builder (and I can press F5 and get some sort of menu, which I think belongs to Map Editor).



  • @meimeiriver You do know that Franklin has two houses in the game? Or haven't you got that far through the story? The first house belongs to Franklin's auntie, not Franklin.



  • @LeeC2202 OMG! This is hilarious. :) No, LOL, I thought he just had the one house! Cripes! I guess I need to play some more first to unlock his second hime! Doh on me.




Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.