Log in to reply
 

Add-on tuning part name problem



  • I have a problem with one small thing but i couldn’t fix it
    which is naming tuning part ingame
    in carcols when i name the tuning part and try it, the tuning appears but the name doesn’t, it show’s as NULL
    does anyone know how fix this problem?



  • @Abdulrhman1 yes, you have to add the name and hash code in the lang_folder. im on mobile at the moment. but if you read the addon tutorial from ImNotMental you see the file you have to change and how to do this. http://www2.imnotmental.xyz/guide/add-on-vehicles-tutorial/
    its explained in step 17
    the hashes you can create with openiv



  • @TobsiCred Thanks for the help! :thumbsup_tone1:



  • @Abdulrhman1 no problem :) if you need/want a example you can download my e21 mod and look what names i write in x64/lang "language. rpfs" and how it must written in data/carcols. if u need help creating hashes in openiv, you can ask me again, but the only you have to look is that "hex" is chosen



  • @TobsiCred i know how to create hashes but how do i save it to gxt2 format ?
    i don’t get it :confused:



  • @Abdulrhman1 you can use notepad++ or editor, to create the file. After you have done, Save As “global.oxt” instead of .meta or .txt then switch back to OpenIV, navigate to “GTAV\mods\update\x64\dlcpacks"your add on"\dlc.rpf\x64\data\lang”, Drag & drop your “global.oxt” into every rpf in that folder.
    If you done correctly, OpenIV will help you convert into “global.gxt2” file type. if you got no rpf's in this path take them from my e21 mod and then replace my gxt2 with your oxt. just drag and drop



  • @TobsiCred This is my global.oxt
    0_1485418614477_بدون عنوان.png
    Is there something wrong ?
    because when i import it OpenIV says its corrupted



  • Come on with that ZL1 already :p

    Always wondered who actually cares about custom names for tuning-parts.
    Proper make and model name, that I can relate to.

    Why not simply re-use the vanilla names like MNU_HOOD1 etc?



  • @ReNNie I don’t like vanilla names for some reason
    i want to make my own.
    i was going to make the zl1 as a secret until release but who cares :smile:
    0_1485420484275_1-compressed.jpg



  • @Abdulrhman1 damn thats hella sexy cant wait for that car!



  • @Abdulrhman1 thats wrong, no empty space between the lines. also your hexcode looks not correct. have you marked hex in the checkbox hash section of openiv? must look like the following

    Version 2 30
    {
    hexcode = tuningpartname
    hexcode2 = tuningpartname2
    }

    as in the tutorial link above in step17, you have to press tab key before the hexcode. shows not correctly in my post

    in a few hours i am at home and can do a correct version for you



  • @Abdulrhman1 so i`ve done the file for you http://sharemods.com/pi5u8r2xaclg/global.oxt.html

    must look like this
    0_1485440129589_1.JPG

    for correct hashcodes use these settings

    0_1485439967448_hash.jpg



  • @TobsiCred ok i understand what you meant now
    thanks for the help:thumbsup_tone3:



  • Hi guys, I've got some problems on naming in the .oxt file.
    I followed the steps above but OpenIV still doesn't let me to import the .oxt file into the lang folder. I would like to know what the problem is.
    Can anyone help? Much appreciated! :)

    alt text

    alt text



  • @andrewyhy means you got the same line in there twice so delete the one that is highlighted.

    you got the same car model referenced twice in there somewhere.



  • @Willief23 Thanks for your reply! But that's the only line that I used for "BNR34". I've tried using "Case sensitive" to generate another hex but no luck. Even I deleted that line, the same error "global.oxt(Line 6): Duplicate key." came up. I wonder for what reason it went error. :confused:

    EDIT: I removed all empty lines and it went fine now. lol



  • @andrewyhy ok wait nevermind i figured it out. You cant have any spaces between the lines. So see how line 3 has mitsu and line 4 and line 6 are just empty lines? Get rid of all the empty lines. And then it will work.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.