Log in to reply

Invalid Model and Crashes

  • Hello Guys (and Girls), i got a small problem. I wanted to install a Mod Package by Gta5Korn and i did everything as instructed but
    whenever i try to spawn some of the add on cars (whether its simple trainer, add on car spawner or whatever) it says invalid model. Therefore i thought
    why not take the Common/Data/dcllist.xml to the mod folder - but then the game simply crashes - why? And how do i solve this whole mess ?
    I'm into modding since gta 3 but something like this never really happened ... oO


  • @DerTopf I am confused when you say you did everything as instructed, but only after the cars failing to spawn did you add the dlclist to your mods folder. When you add addon cars to your mods folder, you must also add the modified dlclist.xml to the update.rpf file in the same mods folder.

    You need to describe in more detail what the mod package is and exactly how and where you installed everything. That means the dlc.rpf file and the modified dlclist.xml file.

  • Just to add to this... I have just downloaded one car pack, this one https://www.gta5-mods.com/vehicles/gta5korn-cars-pack and I have to say, the instructions are pretty poor if it's this one.

    It tells you to create a folder in your mods folder and then tells you to put the dlc.rpf into the normal update\x64\dlcpacks folder. :astonished: Is it any wonder people have problems installing these mods?

    I mean, it says:

    3. Add the following line:

    But it doesn't tell you what file you should be adding that line into. :face_palm:

    Anyway, if it is that one, the instructions should read:

    1. Create a folder named "Gta5KoRn" in \Grand Theft Auto V\mods\update\x64\dlcpacks
    2. Open OpenIV and extract the "dlc.rpf" from the current archive to \Grand Theft Auto V\mods\update\x64\dlcpacks\Gta5KoRn
    3. Copy the dlclist.xml file from \Grand Theft Auto V\mods\update\update.rpf\common\data onto your desktop.
    4. Add the line <Item>dlcpacks:\Gta5KoRn</Item> to the bottom of the list
    5. Save the modified dlclist.xml file and then import it back to the location you extracted it from... \Grand Theft Auto V\mods\update\update.rpf\common\data

  • It is that one. and i copied everything into the mod folder except point 4 of the readme. i think i found the problem - i'll try it out and post later on ^^

  • Problem still remains - Game is not crashing but the cars can not be spawned with the trainer

  • @DerTopf So you've done all 5 points that I listed above, including the dlclist.xml file and you can't spawn them by name using the trainer, is that correct?

    Have you installed this as well? https://www.gta5-mods.com/misc/gta-5-gameconfig-300-cars

    Try the x1 Ped and x1 Vehicle density option.

  • exactly - simple trainer still tells me "invalid model"

    Does not change anything :neutral_face:

  • @DerTopf In that case, something is possibly wrong with how you have installed it.

    Go to the location of the dlc.rpf in OpenIV and post a screenshot of that screen. If you can show the bottom of the dlclist.xml file where you have added that entry as well, that would be even better. You should be able to get them both by putting notepad over OpenIV.. just make the notepad window small, so that it doesn't cover all of the OpenIV window.

  • @LeeC2202 i don't know - it cannot be that difficult oO


  • @DerTopf Okay, so based on that picture, I have two questions.

    1. Are you sure that OpenIV is definitely loading files from the mods folder? You will know that by checking any logs in your main folder to see if there are any errors. The logs you need to check are ScriptHookV.log, asiloader.log and OpenIV.log.

    2. Why do you have every game dlc folder in your mods folder? If you have not modified any of those folders, they don't need to be there. They do need to be in the dlclist.xml file but not in the dlcpacks folder. In theory, the only folder that should be in there, is the one for this addon pack.

    For example, my dlcpacks folder has 34 folders inside it but they are all addon cars, there are no standard game folders in there.

    You hit the nail on the head when you said it can't be difficult... it isn't unless something is going wrong. We just need to find out what that wrong is. Your dlclist.xml fine looks fine, that addon folder looks fine, so maybe the answer lies elsewhere and that's hopefully what the logs will tell us.

  • @LeeC2202 I just made sure that the other files would not be the problem ^^ - anyway
    the openIV log says in serveral places
    "01/02/2017 00:11:42.749 [3080] TRACE: [fiDeviceLocal::getFileAttr] 'update/x64/dlcpacks/Gta5KoRndlc.rpf'
    01/02/2017 00:11:42.749 [3080] TRACE: [fiDeviceLocal::getFileAttr] 'update/x64/dlcpacks/Gta5KoRndlc.rpf'"
    which can not be because it would have to be /mods/update [...] or not?

    Asi and SkripthookV just show the plugins getting loaded
    But replaced cars work fine ?!

  • @DerTopf You don't have that folder in two places do you? I.e. one in Grand Theft Auto V\mods\update\x64\dlcpacks and one in Grand Theft Auto V\update\x64\dlcpacks?

    Are any files being loaded from the mods folder at all in that log file?

  • @LeeC2202 Nope just in the Mod folder. It did load the replaced car this evening - before i kicked it out again because of the low quality interior :confounded: Can i force OpenIV to load the folder?

  • @DerTopf If OpenIV finds a file in the mods folder, it will use that instead of the ones in the game folder. That's why the only files that should be in your mods folder are ones you specifically want to use instead of the game files.

    This is what my dlcpacks folders look like, notice that there is no duplication of the game folders in my mods folder.

    By rights, the only files you should have changed to install this addon, are mods\update\update.rpf, where the modified dlclist.xml and downloaded gameconfig.xml should be (in mods\update\update.rpf\common\data) and the Gta5KoRn folder in mods\update\x64\dlcpacks.

    So if you put your two dlcpacks folders side-by-side like I have done, the right hand side should have a single folder in it.

    If you install any replace vehicles, that's when you copy the game folders into your mods folder.

    alt text

  • @LeeC2202 i deleted the whole mod folder (as there where no mods anyway except for this one) and repeated the whole stuff - still not working - maybe the trainer.ini which is wrong?

  • @DerTopf I presume you tried it by using the "Spawn by name" option as well? In the trainer that is...

  • @LeeC2202 yes. And to make sure it is not the mod - i downloaded another addon car and installed it - still no invalid model... -.-''

  • @DerTopf I've just installed the mod and spawned a car from it, so the mod is definitely working.

    Those lines it tells you to add to the ini file, like the rest of the instructions, are a mess. The first two lines are the same:


    Which could very well cause a problem. But also, the trainer already has a set of values already in that section, so you don't need to add those lines from the readme, you need to use them to replace the existing ones that match in the trainer.

    That shouldn't affect them spawning by name though. When you added that other mod, did that show in the OpenIV.log file as being loaded from the mods folder?

  • No just "01/02/2017 01:22:25.651 [2044] TRACE: [fiDeviceLocal::getFileAttr] 'update/x64/dlcpacks/NC1/dlc.rpf'" again - but the file is definitly in the mod folder...

  • @DerTopf This is my OpenIV entry from that pack:

    01/02/2017 00:21:45.070 [6096] TRACE: [fiDeviceLocal::getFileAttr] 'mods/update/x64/dlcpacks/Gta5KoRn/dlc.rpf' {M}

    So as far as your OpenIV is concerned, your mods folder isn't working like a mods folder, which means something in your installation is wrong.

    Show me a screenshot of your OpenIV that matches this.

    alt text

  • alt text

    Yours is on the left side.

  • @DerTopf My what is on the left side?

  • yes. i found the problem - at leat for the second addon car. because i noticed that the x64 folder was not in the update folder. at least the honda nsx works for now
    But for the nsx i also had to edit the extratitleupdatedata.meta - maybe that is the problem?

  • Alright never mind - found the problem. You corrected the Readme for me but you wrote "<Item>dlcpacks:\Gta5KoRn</Item>" instead of "<Item>dlcpacks:\Gta5KoRn</Item>
    Now the Cars are working fine :D And some of them are pretty awsome :D

    But thank you so much for your time i really appreciate it :) :)

  • @DerTopf Ah, I usually try and avoid using quotes... it is generally accepted that if someone puts something in quotes, you only use the bit inside and not the actual quotes themselves, sorry for the confusion.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.