Log in to reply
 

how to break those texture(livery) limit?



  • Recently i downloaded skyline's F-16D fighting falcon,but it only limit 4 livery ,it means i can't add more then 4 livery,so how do i break those limit?

    Link of the F-16D https://www.gta5-mods.com/vehicles/f-16d-fighting-falcon-usaf-add-on



  • @zh465 you can add more. Just name new textures with higher numbers, eg: falcon_sign_5 and falcon_sign_6



  • @SkylineGTRFreak yea i tried ,but it wont work ,it juz 4 livery ,all livery after falcon_4 wont work,it means falcon_sign_6,7,8...... wont load it only load falcon_sign1~4



  • @zh465 I have just tried this and it works fine with 6 liveries. Texture names must be f16d_sign_5 & f16d_sign_6 etc...

    0_1486216762074_liveries.jpg



  • @zh465 As said by @LeeC2202 above you need to rename the additional liveries textures in the mentioned formatting.

    I would also mention for future reference that it seems —unless I'm wrong— the limit of liveries which can be added to a vehicle is capped to 25 max. as I noticed when trying to add more in some modded vehicles (in such case any liveries after the 25th will not be available and loaded in-game).



  • @LeeC2202 @SkylineGTRFreak @UsernameNotRequired yea i tried this......but it only loaded the first to forth livery and i did renamed that..

    i forgot to say that i use this f16d as replace not add on ,maybe this cause the problem?yea.....i did install the vehicle.meta.
    and..thanks for the replay:smile:



  • @zh465 can you show a screenshot of the texture List in OpenIV?



  • ![alt text](0_1486380211244_upload-5702256a-b9ff-4928-bd17-7e1bfc03832a image url)@SkylineGTRFreak



  • @zh465 I don't think it's that but since it's a weird issue you should check if there is no space before the "f" in "fi6d_sign_" it already happened to me on other things



  • @SkylineGTRFreak ermm i still cant figure out what cause this issue
    @cgz nope,i checked that no problem on the name



  • @zh465

    That's also a lot of 4096x4096 liveries... I've found V likes it to be no more than 5 to 6 in one ytd.
    Have you tried first replacing slots with 2048x2048?

    So, first no more than 6 _sign in 2048 in the ytd. Do they show up?
    Then increase to 10 times a _sign. Then replace some 2048 by 4096. Etc..



  • @zh465 A 4096 x 4096 pixels texture uses a lot of VRAM (48 Megabytes each one) overloading too the UVs and shader per-pixel calculations in the GPU, stressing the hardware (Rage engine in GTA V applies 8 passes to render each pixel on screen, so just multiply and be amazed with the percentage of the game process are you using for a simple 4k texture).
    For the health of the performance and hardware, the limits for each model is managed by the game engine. You can't abuse about that, the engine only assing ~10 Megabytes for each model including textures (approximate value when we see the most heavy models from the game with already compressed textures), and the textures are compressed to Direct Draw Surface (DDS) with Mip Mapping generating more sub-textures. So, always use the lowest resolution possible because each Megabyte in a open world game is precious and Rockstar knows that.



  • @ReNNie The textures are actually 4096x2048, they're rectangular, not square.

    @zh465 Have you tried using the aircraft as an addon to see if you have the same problem? This might be way off base but maybe replace vehicles have an internally imposed limit on the number of liveries, that addon vehicles don't have.



  • @LeeC2202 erm....i think thats the problem ,but trying to figure out what cause that livery cant load in replace



  • @zh465 What vehicle are you trying to replace? I don't think you've mentioned that yet.



  • @LeeC2202 its a f16d and im trying to replace it as LAZER



  • @zh465 Okay, thanks... I will try the same replacement later and see if I get the same problem. It also means I can have a look at the meta files that are directly related to that aircraft, to see if there is anything in there that would indicate any kind of limit.



  • @LeeC2202 any idea about this?or u dont have that problem?



  • @zh465 Here's an image from the f16 used as a replace. As you can see, 6 liveries work fine.

    0_1486587031570_6liveries.jpg



  • @LeeC2202 how you do that?or what i missed to install ?



  • @zh465 I simply renamed the three files to lazer.ytd, lazer_hi.yft and lazer.yft and added them to the patchday3ng folder in my mods folder.

    I then exported the vehicles.meta from the latest update.rpf, added the FLAG_HAS_LIVERY option in the lazer flags section and replaced that back into update.rpf... also in my mods folder.

    I then added two more liveries to the lazer.ytd and spawned the plane as the lazer.



  • @LeeC2202 I found out the problem,it's a small mistake on me , the fifth livery I rename wrongly ,I added one more space on the back,so it cause all of the livery behind 5 won't work.:joy:

    And Yea.....Thanks for helping me out of this problem guys!:slight_smile:



  • @zh465 Glad you got it working. :slight_smile:



  • ah, thought you knew that would give a fault :/
    Also if you break the number range, so sign_3, sign_4, sign_6 etc ... then you'll only see the first 4 and not the rest


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.