Log in to reply
 

Can't spawn some vehicles (singleplayer)



  • So Im trying to spawn some vehicles such as the sultan rs in my trainer, but I get "invalid model". This also happens when I try to spawn any dlc car.


  • MODERATOR

    @Bang758 most likely outdated game.



  • @Bang758 Then something is wrong but as you have told us nothing about what you have installed, or how and where you have installed it, we have no idea how to help.

    You need to tell us exactly how you have your game set up, which version, whether you are using a mods folder, which mods you have installed, what you have installed to use those mods (ScriptHookV, OpenIV etc...), what files you have edited, where you put them etc...



  • @LeeC2202 I used to be able to spawn these dlc cars before I modded the game with addon cars/redux mod, but I was able to spawn with just scripthook v and simple trainer installed.


  • MODERATOR

    @Bang758 Did you bought the game?



  • Also these cars which I can't spawn are dlc cars, the regular cars work just fine



  • @Bang758 Did you install Redux after the addon cars? If you did, then check to make sure you have a gameconfig that allows for more addon cars to be used. Check the dlclist.xml to make sure all the entries are there for the addon cars.



  • @Kwebbl @LeeC2202 Yes I have bought the game and the addon cars work just fine, but cars that came as a dlc to the game don't work.




  • MODERATOR

    @Bang758 Is it like you don't have any dlc cars? I think I had that too. I'm not sure what fixed it. Try re-/installing a custom gameconfig. Or maybe you made a mistake in the dlclist.xml which doesn't let it load correctly.



  • @LeeC2202 The script didn't work, it just crashed my game
    @Kwebbl Yeah it's like I dont have them. My dlclist should be fine or does it break if I add "<Item>dlcpacks:\bmwe38</Item>" for example?



  • @Bang758 I use that script, it works fine... it certainly shouldn't be causing game crashes unless you already have something wrong with your game.

    You need to show us an image of, or post the contents of your dlclist.xml file.

    Oh, and what game version are you running? The version number that is, not Retail or Steam.



  • @LeeC2202 well for some odd reason the game didn't crash, but I can't spawn these vehicles



  • Here is my dlclist.xml:
    <?xml version="1.0" encoding="UTF-8"?>

    <SMandatoryPacksData>
    <Paths>
    <Item>platform:\dlcPacks\mpBeach</Item>
    <Item>platform:\dlcPacks\mpBusiness</Item>
    <Item>platform:\dlcPacks\mpChristmas</Item>
    <Item>platform:\dlcPacks\mpValentines</Item>
    <Item>platform:\dlcPacks\mpBusiness2</Item>
    <Item>platform:\dlcPacks\mpHipster</Item>
    <Item>platform:\dlcPacks\mpIndependence</Item>
    <Item>platform:\dlcPacks\mpPilot</Item>
    <Item>platform:\dlcPacks\spUpgrade</Item>
    <Item>platform:\dlcPacks\mpLTS</Item>
    <Item>dlcpacks:\mpheist</Item>
    <Item>dlcpacks:\mppatchesng</Item>
    <Item>dlcpacks:\patchday1ng</Item>
    <Item>dlcpacks:\patchday2ng</Item>
    <Item>dlcpacks:\mpchristmas2</Item>
    <Item>dlcpacks:\patchday2bng</Item>
    <Item>dlcpacks:\patchday3ng</Item>
    <Item>dlcpacks:\patchday4ng</Item>
    <Item>dlcpacks:\mpluxe</Item>
    <Item>dlcpacks:\patchday5ng</Item>
    <Item>dlcpacks:\mpluxe2</Item>
    <Item>dlcpacks:\patchday6ng</Item>
    <Item>dlcpacks:\mpreplay</Item>
    <Item>dlcpacks:\patchday7ng</Item>
    <Item>dlcpacks:\mplowrider</Item>
    <Item>dlcpacks:\mphalloween</Item>
    <Item>dlcpacks:\alexmods</Item>
    <Item>dlcpacks:\fs450</Item>
    <Item>dlcpacks:\c63w205</Item>
    <item>dlcpacks:\r33</item>
    <Item>dlcpacks:\240sxbn</Item>
    <Item>dlcpacks:\m5</Item>
    <item>dlcpacks:\mrx7fd3s</item>
    <Item>dlcpacks:\yzfsm</Item>
    <Item>dlcpacks:\ktmsm</Item>
    <Item>dlcpacks:\bmwe38</Item>
    <Item>dlcpacks:\lada2107</Item>
    <Item>dlcpacks:\w210</Item>
    <Item>dlcpacks:\skintpack</Item>
    <Item>dlcpacks:\lada2</Item>

    </Paths>	
    

    </SMandatoryPacksData>



  • Also my game version is 1.0.944.2 which should be the latest one



  • @Bang758 If your game was 1.0.944 you would have more patchday folders than that... that's not a 1.0.944 dlclist.xml file.



  • @LeeC2202 Yeah I just realised that too (stupid me) could you post all the missing ones?



  • @Bang758 No... if you have a legit version of the game, you will be able to get them back quite easily.



  • I mean could you post the missing <Item>dlcpacks:\xxxxxxxx ones not the actual folders



  • @Bang758 No... you can find them in the original dlclist.xml in the vanilla game folders.



  • the one in the vanilla folder only has these:

    <Item>platform:\dlcPacks\mpBeach</Item>
    <Item>platform:\dlcPacks\mpBusiness</Item>
    <Item>platform:\dlcPacks\mpChristmas</Item>
    <Item>platform:\dlcPacks\mpValentines</Item>
    <Item>platform:\dlcPacks\mpBusiness2</Item>
    <Item>platform:\dlcPacks\mpHipster</Item>
    <Item>platform:\dlcPacks\mpIndependence</Item>
    <Item>platform:\dlcPacks\mpPilot</Item>
    <Item>platform:\dlcPacks\spUpgrade</Item>
    <Item>platform:\dlcPacks\mpLTS</Item>
    <Item>dlcpacks:\mpheist</Item>
    <Item>dlcpacks:\mppatchesng</Item>
    <Item>dlcpacks:\patchday1ng</Item>
    <Item>dlcpacks:\patchday2ng</Item>
    <Item>dlcpacks:\mpchristmas2</Item>
    <Item>dlcpacks:\patchday2bng</Item>
    <Item>dlcpacks:\patchday3ng</Item>
    <Item>dlcpacks:\patchday4ng</Item>
    <Item>dlcpacks:\mpluxe</Item>
    <Item>dlcpacks:\patchday5ng</Item>
    <Item>dlcpacks:\mpluxe2</Item>
    <Item>dlcpacks:\patchday6ng</Item>
    <Item>dlcpacks:\mpreplay</Item>
    <Item>dlcpacks:\patchday7ng</Item>
    <Item>dlcpacks:\mplowrider</Item>
    <Item>dlcpacks:\mphalloween</Item>
    <Item>dlcpacks:\alexmods</Item>

    So I don't know how I can get the proper one



  • @Bang758 Verify your game files, that will get the original files back for all the vanilla game files.



  • But doesn't that mess my redux mod?



  • @Bang758 That depends on where you have installed your Redux Mod. If you have installed it to your mods folder, then probably not... if you've installed it to your game files, then probably yes.

    The simple fact is, you don't have the correct files for the version of the game you claim to be using. That means that anybody looking at this thread might not believe your game is genuine, which in turn means they won't help... they certainly won't send orignal files, that's pretty much guaranteed.

    Your only option is to verify your game files.



  • Well the reason why I don't have the correct dlclist is, because I installed this mod: https://fi.gta5-mods.com/vehicles/toyota-supra-add-on-stock-more-tuning

    to my original folder and that mod comes with a dlclist which is missing the latest dlcpack things and after that I copy-pasted that dlclist into my mods folder and started to put other addon car mods to it.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.