Log in to reply
 

I need help installing add on vehicles



  • I successfully installed SkyGTRFreak's Spooky gunship, but I cannot get other vehicles to work (such as FoxtrotDelta's M41). I've installed everything according the readme files, but when I go to spawn them (with the Enhanced Native Trainer), it says model can't be found.



  • @CmdrJebus

    'Invalid model' when trying to spawn an Add-On? Then visit:
    Reyser's Add-On Tutorial »
    I'm Not Mental's Add-On Tutorial »

    You have placed the dlc.rpf inside <gamefolder>\mods\update\x64\dlcpacks\name of the add-on pack ?
    And then added a new entry <Item>dlcpacks:\name of the add-on pack\</Item> in dlclist.xml inside <gamefolder>\mods\update\update.rpf\common\data ?
    And use the correct spawn name to call it?



  • @ReNNie Isn't Reyser's tutorial about creating add-ons for replacement vehicles and weapons? Why did you include it here?



  • @V4D3R

    The tutorial also explains what the references inside dlclist.xml do and how a dlc.rpf is built up internally.
    So, once the poster understands that method of linking within the files, he'll never run into problems ever again.
    And he seems to be interested in adding, so ...



  • @ReNNie OK thanks for the explanation.

    Also adding another thing: changing the gameconfig will solve the problem, the OP doesn't seem to have installed many add-on vehicles, so it will be enough, for now.



  • @V4D3R
    Hmmm I don''t think the gameconfig.xml has anything to do with the Invalid Model error?
    When the game doesn't support more add-on packs or even the total number of yft's it can load overall in all packs is reached, it will just crash with a generic error displayed...



  • @ReNNie Yes, it can solve the issue. I have around 100 add-on vehicles, and whenever I use the original gameconfig, 99% of them can't be spawned, I get the invalid model error, and sometimes it crashes. And for new users this add-on pack creating is difficult, so I usually tell people to change the gameconfig, F7YO's to be exact to get rid of the invalid model error. Not everyone reaches the add-on limit, you know. For users who use less than 150 add-ons, this method will be useful.
    Unless you have reached the add-on limit, there's no need to combine every add-on to one pack. The above method will not work forever, when you reach some point, you will have to combine add-on dlcs.



  • @ReNNie When version 944 came out, having just two addons caused that error for me. With just the addition of that gameconfig, I have my 30 existing addons and those two packs you sent me and all that was changed was the gameconfig.

    It's probably the most critical file you can use to solve the problem, because the problem is caused by insufficient memory pools to hold the resource data. So when the game tries to look for it, it isn't there and the only error it can generate, is one based on the fact it thinks the target of the resource call, is somehow invalid... because it's missing.



  • @ReNNie I need help with my files because when I download them I go to my documents and instead of the car being in a folder its in a ''RAR File'' is there a way to change that?????



  • @bryannocera1 Please create a thread with your own problem, so people can get the information they need off you and then they can provide you with the solution, without derailing the OP's problem. Thanks.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.