Log in to reply
 

Corrupted file (Backup is not the solution)



  • So, I'm really pissed off right now. I've been working to get every car on the game replaced. It's been almost a 2-month work by now and I do have all vanilla backups. What happened was, suddenly, I couldn't open the vehicles.rpf inside the x64e.rpf from my mods folder, with OpenIV saying that the file was corrupted. I tried dragging it out and putting it back, still doesn't work and now I'll probably have to put every file back, and even worst, I had some edited texutures that I used for myself. My question is, is there any way that I can recover the file? Even if it's partially? I tried the windows older version restore, but there was no file for me to restore. If anyone can help, I'll be extremely happy.



  • @guilhermetod If the file is actually corrupted, then there's not a lot that can be done unfortunately. Have you tried dragging the vehicles.rpf out of x64e.rpf and then tried to open it from outside that file?

    As long as you have associated rpf files with OpenIV, it will open them from anywhere. Other than that, I'm not sure what else to suggest.

    Years ago, when disks were small, disk sector editors were quite common and frequently used... I once spent 13 hours manually relinking a file from a corrupted disk... but that was something like a 20Kb file. rpf files are 2GB, I wouldn't even think about trying to relink clusters to bypass corruption in that, if it was possible at all.



  • Sorry to hear that mate.

    This was a valuable lesson in V teaching you the art of backups.

    I backup an add-on every time I make edits to it.
    And save all of them to another harddisk too. So, when editing I have two backups. At the most I loose a day of work...
    And I keep the deflated meta files etc too. So rebuilding an add-on is basically copy paste all the lines and drag the models back in.

    Same on textures. Backup, backup... Backup.
    Just don't delete that stuff in a whim of brainfog as I apparently did on my IV retexturing :/

    Sorry I can't be of more help. To my knowledge OpenIV can't restore a corrupted rpf

    @GooD-NTS ...or can it?



  • @guilhermetod You could maybe use SparkIV as well, to try and open the archive.

    Also. copy the corrupted .rpf files first: if there's a bad sector, at least you won't run into that when it's at a different location (it will likely still be corrupted, of course).



  • Thanks everyone who answered, I'm really happy that y'all tried to help. @LeeC2202 That was actually the way I noticed something was strange. I was using the search tool to try to find cars and the ones on x64e weren't showing up. I was still having access to the file however, should've copied all of em, but instead I closed OpenIV thinking it was just a problem that was going to solve when I restarted, but still, thaks for the suggestion. @ReNNie Yeah, I planned on backing up everytime, I had a full game Vanilla backup and a modded one from about a month ago, wich I planned to update everey 2-3 days, but procrastination strikes once again. @meimeiriver Well, it was a great idea, however, I already restored almost everything that I lost. Thank God I had all of the original .rar and .zip files from the cars I previously downloaded. Plus, the most worked files with textures were on patchupdates, I shouldn't be that pissed off, I really thought I lost a lot of thing but didn't haha. The worst thing I lost was my vehshare wich had a lot of rims, but it's working right now. Thanks everyone.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.