Log in to reply

All Asi plugins work perfectly but nothing else !

  • I just got this....


    Pherhaps I should also remove the Enhanched native trainer ?
    And I also remember first time I installed the helicopter I used the original update.rpf but I also have an untouched version wich I will put back and try to verify again.

  • @HueyPilot0014 You can't modify the original game files with the retail version, it will always generate that error. If you have done a verify, the update.rpf should be back to the untouched version anyway.

    ENT (which I missed in my instructions, sorry about that) shouldn't affect the verification.

  • Okay so I took out the Enhanced native trainer also put back the original update.rpf and verification worked ! Also played the gamed for a few minutes and everything seems normal again so nothing installed at all.
    So now I install the Scripthook files as you said and restart the game to check if it loads the scripthook dot net in the log ?

  • I Just noticed I got a new asiloader log file and cant find any other log file.
    But as far as I can tell it had loaded the scripthookv dot net.asi so can i now install you`re script ? And what does it do ?

  • @HueyPilot0014 The script just displays a clock on the screen and the current FPS... it's just a simple script I have to check peformance when I am writing my mods. It does very little so it's an ideal test script.

  • I made the text file as you asked but now asiloader log says this:

    // GTA V ASI LOADER (build May 2 2015)
    // (C) Alexander Blade 2015
    LIB: "C:\Windows\system32\dinput8.dll" => 000007FEEE7A0000
    API: "DirectInput8Create" => 000007FEEE7A4820
    API: "DllCanUnloadNow" => 000007FEEE7B20DC
    API: "DllGetClassObject" => 000007FEEE7B2014
    API: "DllRegisterServer" => 000007FEEE7C1050
    API: "DllUnregisterServer" => 000007FEEE7C1064
    LOADER: Loading *.asi plugins
    ASI: Loading "D:\Gta5\ScriptHookVDotNet.asi"
    "ScriptHookVDotNet.asi" failed to load
    LOADER: Finished loading *.asi plugins

  • Removed the file again same result

  • @HueyPilot0014 This is bizarre... :confounded:

    What does it say in the ScriptHookV.log?

  • I cannot seem to find it. It should make a log by itself right ?

  • @HueyPilot0014 Yep

    I can't post my contents because the game is loading to test an addon.

  • @HueyPilot0014 I was just about to say that scripthook dll is broken... I got caught out by the decimal separator, I thought it said 1.219KB, but it's actually 1,219KB... :D

    I'm just going to try removing all the scripts in my main folder, to try and mimic your setup, just to make sure a log should be generated... give me a few minutes.

  • Sure think i have to be going to bed anyway 😁 but i'm curious what will happen on you're system !

  • With just that simple script in, you should get an asiloader.log like this:

    // GTA V ASI LOADER (build May  2 2015)
    //     (C) Alexander Blade 2015
    LIB: "C:\Windows\system32\dinput8.dll" => 000007FEEA090000
    API: "DirectInput8Create" => 000007FEEA094820
    API: "DllCanUnloadNow" => 000007FEEA0A20DC
    API: "DllGetClassObject" => 000007FEEA0A2014
    API: "DllRegisterServer" => 000007FEEA0B1050
    API: "DllUnregisterServer" => 000007FEEA0B1064
    LOADER: Loading *.asi plugins
    ASI: Loading "M:\Program Files\Rockstar Games\Grand Theft Auto V\ScriptHookVDotNet.asi"
         "ScriptHookVDotNet.asi" => 000007FEE0360000
    LOADER: Finished loading *.asi plugins

    and a scripthookv.log that looks like this:

    // GTA V SCRIPT HOOK (build Dec 15 2016, v1.0.944.2)
    //     (C) Alexander Blade 2015-2016
    [23:28:38] INIT: Started
    [23:28:38] INIT: Success, game version is VER_1_0_944_2_NOSTEAM
    [23:28:38] INIT: Registering script 'ScriptHookVDotNet.asi' (0x000007FEE03614A0)
    [23:28:44] INIT: Pool 1 extended
    [23:28:44] INIT: Pool 2 extended
    [23:28:44] INIT: Pool 3 extended
    [23:28:44] INIT: Pool 4 extended
    [23:28:50] INIT: GtaThread collection size 188
    [23:28:50] INIT: wnd proc 0x00000000FFFF0857
    [23:28:50] INIT: IDXGISwapChain 0x000007FEF0675AE0 (0x000007FEF069B2F8)
    [23:28:50] INIT: IDXGISwapChain set
    [23:28:50] INIT: DX init started
    [23:28:50] INIT: DX feature level B000
    [23:28:50] INIT: DX init succeeded
    [23:29:44] CORE: Requesting thread creation
    [23:29:44] CORE: Creating threads
    [23:29:46] CORE: Started control thread, id 27 active 1
    [23:29:46] CORE: Started thread 'ScriptHookVDotNet.asi' (0x000007FEE03614A0), id 28 active 1
    [23:29:46] CORE: Launching main() for 'ScriptHookVDotNet.asi' (0x000007FEE03614A0), id 28
    [23:30:03] UNINIT: Unregistering script 'ScriptHookVDotNet.asi'

    and finally, a scripthookvdotnet.log like this

    [23:29:46] [DEBUG] Created script domain 'ScriptDomain_E6036300' with v2.9.4.
    [23:29:46] [DEBUG] Loading scripts from 'M:\Program Files\Rockstar Games\Grand Theft Auto V\scripts' into script domain 'ScriptDomain_E6036300' ...
    [23:29:46] [DEBUG] Successfully compiled 'FPSDisplay.cs'.
    [23:29:46] [DEBUG] Found 1 script(s) in 'FPSDisplay.cs'.
    [23:29:46] [DEBUG] Starting 1 script(s) ...
    [23:29:46] [DEBUG] Instantiating script 'FPSDisplay.FPSDisplay' in script domain 'ScriptDomain_E6036300' ...
    [23:29:46] [DEBUG] Started script 'FPSDisplay.FPSDisplay'.

  • So any idea what's wrong on my end ? Because I'm not getting any of these :(
    But I'm gonna switch of the night catch back up to you tommorow ! :)

  • @HueyPilot0014 Np, I'll be here. :D

  • Ok, something I have just been reading about something that I didn't know existed on Windows 7, the blocking of dll files that have been downloaded from the net.

    If you right-click the ScriptHookV.dll file, does it give you the option to "Unblock" the file?

  • @LeeC2202 I'm not longer a pirate I decided to go and purchase the game. Thanks for making me a better person :).

  • @Chouhdry If that's true, then that's good.

    Just remember a couple of things and you will do fine. First, if you have a question, start a new thread for it, don't ask on someone else's question. Every problem is unique, no matter how similar they might seem, so they have to be dealt with individually.

    Second, make sure you follow the tutorials and use a mods folder and have your game fully updated to make it easier for people to help.

  • Sorry for my late reply here but nice to see our other friend went legal ! Have been busy with work on this end....
    But soon as I get the change I will check the dll files to see if I can unblock and you will hear from me !!

  • Update time ! I decieded to google for the dll problem and at first could not find anything with the dll files I need in Gta 5 but then I read if you download a zip file containing dll files you need to deblock it first ! So I did unlock the zip files and reinstalled the files back into gta 5 main folder. But still if I start the game no log files are created ? I don't have any scripts in the scripts folder right now....

  • @HueyPilot0014 You don't have two copies of the game folder do you by any chance?

    I am really clutching at straws now because there is nothing that I have seen from your setup details, that would give any indication of there being anything wrong.

    The only time I have ever seen this kind of situation, was when someone was trying to set up two game folders, for modding and online, and they were modding one folder but the shortcut was running the game in the other folder. So no matter what they did, nothing ever appeared in the modded game folder because that wasn't actually being used.

    Although that wouldn't make sense because your asiloader.log is getting created... it is still getting created isn't it?

  • No I wish it was as simple as that but I only have 1 folder ! And yes asiloader log is still being made and keeps saying that it cannot load scripthookvdotnet.asi.....

  • @HueyPilot0014 Hmmm, just found another similar problem on reddit... can you try downloading ScriptHookVDotNet 2.9.3 and trying that.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.