Log in to reply
 

Add-on Cars



  • Ok, so I wouldn't be posting this if I haven't tried everything already.

    I have 6 car mods, 5 addon and one replacer

    So I have followed the read me instructions for each mod word for word and the only one that works, other than the replaced one, is the 370z (I have no idea why, it wasn't the first one I installed and it wasn't the last)

    I'm using the unlimited addon config, as well as the addon car spawner

    I'm not sure if I'm just being dumb, because I tried modding gta a while ago and the same thing happened, only one worked.



  • @jasohazard
    The rest says 'invalid model' or what?

    Show us your dlclist.xml from inside mods\update\update.rpf\common\data



  • @ReNNie No, it just doesn't spawn the vehicle.
    Does it have to be in the mod folder? I was just using the direct path because I have a back up of the original game.
    I would do a screenshot but can't upload it directly. Here's a copy paste directly from my dlclist
    <SMandatoryPacksData>
    <Paths>
    <Item>platform:\dlcPacks\mpBeach</Item>
    <Item>platform:\dlcPacks\mpBusiness</Item>
    <Item>platform:\dlcPacks\mpChristmas</Item>
    <Item>platform:\dlcPacks\mpValentines</Item>
    <Item>platform:\dlcPacks\mpBusiness2</Item>
    <Item>platform:\dlcPacks\mpHipster</Item>
    <Item>platform:\dlcPacks\mpIndependence</Item>
    <Item>platform:\dlcPacks\mpPilot</Item>
    <Item>platform:\dlcPacks\spUpgrade</Item>
    <Item>platform:\dlcPacks\mpLTS</Item>
    <Item>dlcpacks:\mpheist</Item>
    <Item>dlcpacks:\mppatchesng</Item>
    <Item>dlcpacks:\patchday1ng</Item>
    <Item>dlcpacks:\patchday2ng</Item>
    <Item>dlcpacks:\mpchristmas2</Item>
    <Item>dlcpacks:\patchday2bng</Item>
    <Item>dlcpacks:\patchday3ng</Item>
    <Item>dlcpacks:\patchday4ng</Item>
    <Item>dlcpacks:\mpluxe</Item>
    <Item>dlcpacks:\patchday5ng</Item>
    <Item>dlcpacks:\mpluxe2</Item>
    <Item>dlcpacks:\patchday6ng</Item>
    <Item>dlcpacks:\mpreplay</Item>
    <Item>dlcpacks:\patchday7ng</Item>
    <Item>dlcpacks:\mplowrider</Item>
    <Item>dlcpacks:\mphalloween</Item>
    <Item>dlcpacks:\patchday8ng</Item>
    <Item>dlcpacks:\mpapartment</Item>
    <item>dlcpacks:\mpxmas_604490</item>
    <Item>dlcpacks:\mplowrider2</Item>
    <Item>dlcpacks:\mpjanuary2016</Item>
    <Item>dlcpacks:\mpvalentines2</Item>
    <Item>dlcpacks:\patchday9ng</Item>
    <Item>dlcpacks:\mpexecutive</Item>
    <Item>dlcpacks:\patchday10ng</Item>
    <Item>dlcpacks:\mpstunt</Item>
    <Item>dlcpacks:\patchday11ng</Item>
    <Item>dlcpacks:\mpimportexport</Item>
    <Item>dlcpacks:\mpbiker</Item>
    <Item>dlcpacks:\patchday12ng</Item>
    <Item>dlcpacks:\patchday13ng</Item>
    <Item>dlcpacks:\ssti</Item>
    <Item>dlcpacks:\370z</Item>
    <Item>dlcpacks:\NC1</Item>
    <Item>dlcpacks:\m5</Item>
    <item>dlcpacks:\rx7tunable</Item>
    </Paths>
    </SMandatoryPacksData>



  • @jasohazard Well the tabs didn't work but they are all aligned if that matters



  • @jasohazard I just posted a topic about having issues.....then I looked at yours here and noticed 1 thing...your last entry is the rx7tunable....it was also my last entry. I removed it and game was fine. Might just be a coincidence but it takes 2 minutes to try.



  • And? The dlclist.xml doesn't look off.



  • @jasohazard said in Add-on Cars:

    <item>dlcpacks:\rx7tunable</Item>

    There is an error on that line, the first item should be Item

    Elements are case specific and must match to be valid.



  • @LeeC2202 Would that really cause all but one of them to not work though? I have already switched back to my original file to start over but I'll try that when I get to it. Thanks.



  • @jasohazard Well after redoing everything and following the advice about fixing the i in my dlclist it all seems to work now. I went and opened up the game to make sure each car worked before moving on to the next one.



  • I'm standing here with my mouth open. Not a pretty sight.
    Didn't think uppercase/lowercase made such a big difference in the xml's.
    I'm thinking this isn't the case inside the meta's? Right, @LeeC2202?


  • MODERATOR

    @LeeC2202 I dunno, <item> works fine for me.



  • @V4D3R it will work, as long as the closing tag is the same, they have to match, doesn't matter if it's lower case or upper case, they just have to match.

    So this is valid
    <Item>dlcpacks:\370z</Item>

    so is this
    <item>dlcpacks:\370z</item>

    but this isn't
    <item>dlcpacks:\370z</Item>


  • MODERATOR

    @LeeC2202 "Facepalm" :face_palm_tone1:
    I didn't see it. Thank you.



  • @V4D3R I had never seen it until this problem. Notepad++ and XML Tools, essential for maintaining XML files. It validates them and tells you where the errors are.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.