Log in to reply

Strange issue with gameconfig and add ons

  • So as of today my game no longer loads fine from having my usual add ons installed. You heard right, add ons that were working perfectly up until yesterday...

    All I did was install another car for testing, I had edited the files a bit so I thought it was my fault at first. I proceeded to delete it from dlclist to see if that was the issue. but noooope the problem stayed the same so I was baffled. I hadn't changed anything else. I looked up the name of the error and it's from supposedly exceeding the gameconfig.xml limit, but I have a custom one for limitless cars! It worked til the day before!?

    After that I indeed tried cutting down the dlcs for test, and it lets me add 13 of them after that it will crash.
    So I know I could start compiling them all in one, but that takes a lot of time and it's prone to errors. Also wouldn't like to do all that if the solution(?) is simpler.
    And the most amazing part is that everything worked up until yesterday... so wtf??

    Thanks to anyone who decides to help.


    Was it a car... Or a car with tuning?
    Because playing around with the gameconfig.xml let's you increase the number of models the game can hold. But a single tuning part counts as just as much as a car model. As in yft = yft.

  • @ReNNie Hmm what do you mean? I didn't touch the gameconfig and I uninstalled the car soon after (tho it was working fine when I later re-tried installing it with fewer add-ons to see if that made any problems). It did have some tuning but as I said I uninstalled it so it should create problems.


    Just saying. But it seems strange indeed.

    Oh no, on second thought it isn't. You deleted the entry from dlclist.xml but still had it in the add-on folder. Apparently the game still loads those models but can't use them ingame.

    Let me explain.
    Last year I was also messing around with add-on peds and while doing that copied the entire componentpeds.rpf (don't ask me why, but I did) to my test.rpf that I use to import stuff to check out in OpenIV. So not loaded in dlclist.xml!!

    I got the error related to gameconfig.xml and couldn't get my head around it... Finally decided to delete the componentpeds.rpf and Blammo, my game loaded just fine.

    You can test my theory yourself?

  • That's a nice theory and I didn't know gta still "loads" the files! But I have deleted the dlc completely so I don't think that's it for this case :( Atm only folders are the dlcs I had already, all others are gone (rare cases that I leave a folder there anyway)

    EDIT: You say I should try moving away the whole folders of the 50 DLCs excluding the 13 that work (at a time) and try adding from there?

  • This is why I'm baffled, I have the DLCs set up exactly as they were yesterday and it will just crash regardless, no other DLCs in the folder either... :( It's like suddenly I'm not allowed to have more than 13 custom DLCs

  • @ReNNie said in Strange issue with gameconfig and add ons:

    Apparently the game still loads those models but can't use them ingame.

    It can't because the game doesn't know the mods folder exists, only OpenIV knows about the mods folder.

    I have just deleted one entry from my dlclist.xml and that entry is never listed in the openiv.log.


    tja, dunno ... I'd just try to increase numbers regarding vehicles and models in gameconfig.xml
    I have those numbers jacked up pretty hard atm (which is also the reason my games crashes from time to time after anywhere from 10 minutes to 1,5 hr :/
    Still need to find a better balance tho I doubt the game will let me have numerous add-on vehicles and peds all at the same time)

    @LeeC2202 I think I saw what I saw ... but then again;
    When it comes to modding V most times I feel more like Sylvester than like Tweetybird, savvy?

  • Yea I get you, but the biggest issue is: why could I add unlimited add ons til yesterday now suddenly I'm limited?" Already had gameconfig edited :confused: I guess it will remain one of humanity's biggest mysteries LoL


    And 13 isn't exactly limitless now is it :/

  • @ReNNie Well yea, I had like 40 before :(

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.