Log in to reply
 

I need help with GTA5 trainers



  • Alright so basicly , I need help, from an expert or something because I asked several people and non of them figured out what the problem was

    My problem is that my trainers wont work anymore after the latest update
    What I've tried:
    Copied all the files I need from a friend who's trainer is actually working
    Tried 3 different updated ScripthookV.dll downloads
    Tried different trainers
    Tried it with a new clean copy
    I asked a PC modder who made his own trainer template for help and he doesn't know what the problem is neither.
    A screenshot of my GTA5 Directory :
    http://prntscr.com/en78g9

    Sorry if my grammar is weird sometimes , I'm Dutch and 16 so my English isn't the best , but I'm trying to improve it every day.

    If someone could help me I would really appreciate it ,



  • Sounds like it might be the ASI loader. Download the newest ragehookplugin, and just replace the dinput file. If it still doesn't work after that, go into OpenIV. Once your in OpenIV, go to the tools tab, and select asi manager. Look at the ASI Loader option. If you don't have it, go ahead and hit install. If you do have it, un-install it, then re-install it. If that doesn't work, best guess would be to uninstall everything having to do with gta v and re-download it.



  • this might sound stupid but I didn't get a dinput file in the ragehookplugin



  • I tried the Xinput dll but that didnt work



  • @Apelops You don't have an asiloader.log file in your directory, which means that it isn't running... in fact, I can't see any log files from anything. Do you have 2 GTAV folders by any chance?

    If not, make sure to install the ScriptHookV files from here http://www.dev-c.com/gtav/scripthookv/

    The one that comes with OpenIV is not guaranteed to be up to date, so that link is the only place you should download it from, to be sure of getting the right version.

    Once you have downloaded and extracted it, right-click the dll file and check if you have an "Unblock" option on it, sometimes, Windows can block dll files you download from the internet.

    Also make sure that it isn't being blocked by any security software you might be using, so check your quarantine logs to make sure ScriptHookV.dll isn't in there.



  • @Apelops that is weird. Yeah, there is definetely an issue here. If you didn't get a dinput8 file from ragehookplugin, you might have gotten it from the wrong source. Make sure to get it from https://ragepluginhook.net/



  • @TheLoneWolf293 I'm confused why they need to get ScriptHookV from the Rage plugin site. I can't see any RPH related files in that directory and they didn't mention that plugin in their post.

    They should be getting ScriptHookV from the ScriptHookV page. Or is ScriptHookV known as the Rage plugin in some circles?



  • I did install it from the website ,
    http://prntscr.com/en857d



  • @Apelops Where has all that come from? That wasn't in your first screenshot?

    Edit: Don't panic over the wait between posts, we won't disappear on you.



  • @LeeC2202 I reinstalled all files , but yeah I also thought it was weird i didnt get any log files



  • @LeeC2202 that is the Ragehookplugin folder



  • @LeeC2202 I thought ragehookplugin comes with dinput8, an ASI loader. Right?



  • @TheLoneWolf293 I don't know but you should always get plugins from their homepage, just in case any other plugins are using an outdated version of those files. That's why you are advised to never use the asiloader that comes with OpenIV.



  • @Apelops If you have anything installed in your GTAV folder that is not shown in that first screenshot, you need to tell us. Anything you have installed could potentially cause the problem, so we need to know what you have.



  • @LeeC2202 my mistake, dinput8 might not be an ASI loader... sorry for the hassle.



  • @TheLoneWolf293 No, it probably is the same file, it's just that to diagnose problems, reliable sources and files are absolutely essential.

    And it's no hassle, honestly.





  • @Apelops That picture doesn't show a single file from the RagePlugin and if you had installed it, that main folder would be absolutely full of files, because it dumps them everywhere.

    So wherever you installed it, it wasn't in the GTAV folder... that's why I asked if you had two GTAV folders, to see if things were getting installed into different locations. If they were, that would explain the lack of log files.



  • I thought you ment I had to download rageplugin but not install the plugin it self



  • @Apelops To get a trainer working, you need four files. ScriptHookV.dll, dinput8.dll, trainerv.asi and trainerv.ini

    If you have all those in your game folder and no logs are being generated, none of those files are running.

    So...

    1. Do you have more than one GTAV folder?
    2. Have you right-clicked the ScriptHookV.dll file and checked that it isn't blocked?
    3. Have you checked your security software logs, to make sure any files in your GTAV folder have not been quarantined for any reason?


  • Also, I don't understand why your version.txt file is dated 2015. That should get updated with every update, so it shouldn't be 2 years old.



  • @LeeC2202 The version.txt file in the root folder doesn't get updated. The one in update.rpf does.



  • @Unknown-Modder Mine does, mine's dated 26-02-2017... oddly though it has the same contents as an old backup file... that's confusing. :\



  • @LeeC2202 Well, maybe it's Steam or R* Warehouse related (if you've got the Steam or R* Warehouse version) or you have recently made some changes. But I can assure you that R* doesn't update the original version.txt file.



  • @Unknown-Modder I bet I know what caused mine to update... I have the retail version and whenever I remove ScriptHookV to update it, it always downloads a small update, really quick. I wonder if it's that.

    Never understood why, it's as if the dinput8.dll file going missing makes it think something has gone wrong with the game files. My mistake then... :(


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.