Log in to reply
 

Why Won't Some ASI Scripts Load?


  • MODERATOR

    I suppose that this topic is more or less borderline troubleshooting/modding discussion, but I have noticed that sometimes an ASI script will stop working. I was using the OpenInteriors.asi script before the most recent update, and after, I got a Script Hook critical error. At first, I assumed I was just out of luck, until recently, when @SkylineGTRFreak couldn't get another ASI script to work. The script was written by @Oskar and worked perfectly until @SkylineGTRFreak upgraded his PC. Afterwords, it just stopped working. From what I gather, there was no error message or any thing. Could another script be interfering? Any ideas or similar issues?



  • @nathanjamesddg151 i Had that issue with Destroyer.asi . basically Press the 7 key slowly and keep it pressed for a whole second. other than that. i would recomend using .dll method. Oskar would know.


  • MODERATOR

    @FoxtrotDelta hmm... I wonder if @SkylineGTRFreak tried that. It still works for me though. But that still doesn't answer the why this is happening.


  • MODERATOR

    @nathanjamesddg151 So it's skyline's new rig?Does he have all kinds of Visual C++ & .NET installed?
    I'm having C++ 2005,C++2008,C++2010,C++2012,C++2013 AND .NET4.5 .NET4.6 installed in my rig though D:


  • MODERATOR

    @Elope I don't know what stuff @SkylineGTRFreak has installed, though that sounds like a likely reason why the script isn't working. @Oskar would probably know what things would be needed for the script to work.



  • @nathanjamesddg151 @SkylineGTRFreak Check the Scripthook log and tell what it says.
    @FoxtrotDelta And what do you mean by .dll method ?



  • Just don't ask me why, but I replaced the .asi with the exact same one again and it works now... Whysoever.



  • @SkylineGTRFreak must be an antivirus thing. Glad it works.


  • MODERATOR

    @Oskar So... the OpenInteriors.asi mod works somewhat. It cannot open any online maps, but story mode maps are okay (I have to disable loading online maps in the config ini file, otherwise it won't work). Looking at old comments from the mod's author, who hasn't been online since February, it appears that a modded RPF might be interfering with the script. Now I'm not sure which RPF that might be. Here's a screenshot of the error: http://imgur.com/a/yIFfi Any ideas on what RPF that might be and where it would be located?



  • Imma test something tomorrow. I have been working on a carrier catapult and arresting hook script for quite some time and I've also loaded the carrier with my script. But the script somehow also doesn't wanna load anymore. But I'll have a look at it tomorrow.


  • MODERATOR

    @Oskar cool. Let me know how that works.


  • MODERATOR

    @Oskar Wait, so you're not using the OpenInteriors.asi script? And do you have any idea on how open all online interiors if this script won't work?


  • MODERATOR

    So I finally figured out that it was a problem with my gameconfig file. Once I replaced that, it worked fine. Just an update.


  • Banned

    Erm, dude, could you be more specfic than "a problem"?


  • MODERATOR

    @BikerJohnny Like my OpenInteriors.ASI wouldn't load, a ScriptHookV Critical Error or something. Replacing my gameconfig seemed to fix it.


  • Banned

    K, that isn't even my problem, shit just won't load. Thanks anyway



  • @FoxtrotDelta do u really speak persian? then try this سلام واقعان انقدر زبان بلدی؟؟؟؟



  • @pouriya-tajmehrabi سرود ملی ما در زبان فارسی است. من پاکستانی هستم. ما فارسی صحبت بیش از حد I am From Pakistan. 50% of our population can speak and write Persian. our national Language (Urdu) is a mix of Persian/Arabic/Hindi & English. Our national Anthem is in Persian. Our Founding Fathers Spoke Persian and British English as their Mother tongues.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.