Log in to reply
 

Apartments hosed?!



  • Just tried to use SPA to enter a high-end apartment: fell right thru an empty scructure. So I figure SPA is buggy. Then I use Simple Trainer to do the same: either game immedately crashes, or I fall down a long shaft of nothingness again. So I try Menyuu. Same difference.

    So, what's up with the fancy apartments? And yes, I have the game set to load the MP maps, of course. But the high-end apartments seem to crap out, with every tool I use.



  • Seriously, could someone test whether the fancy Apartments still load for them in Simple Trainer? I feel something weird is up with them.



  • @meimeiriver It's totally a "YOU thing". I have been using SPA mod since first release, and it works as advertised. The symptom you described tells me you have conflicting mod somewhere.In his description, he tells you what mods cause conflicts. Also if using OAI, if the settings are conflicting, it will cause you to fall through the ground.



  • @eshenk said in Apartments hosed?!:

    @meimeiriver It's totally a "YOU thing". I have been using SPA mod since first release, and it works as advertised. The symptom you described tells me you have conflicting mod somewhere.In his description, he tells you what mods cause conflicts. Also if using OAI, if the settings are conflicting, it will cause you to fall through the ground.

    Not sure what you are talking about. I've been using SPA since ages. And no, my OAI settings aren't conflicting: I'm not an idiot. This is a fairly recent thing. I suspect the MP maps aren't being loaded (properly?) somehow, but have no idea why.



  • @meimeiriver No need to get defensive.I was merely trying to assure you that SPA works just fine....at least on my end it does, LOL.



  • @eshenk said in Apartments hosed?!:

    @meimeiriver No need to get defensive.I was merely trying to assure you that SPA works just fine....at least on my end it does, LOL.

    Thing is, it's not even an SPA conflict: apart from having disabled OAI and SPA altogether, for the test, none of the trainers seem to be able to load the mp maps even. You fall right to the ground (or the game just crashes). Actually, flying up and down up a bit (inside the empty building), I was able to land inside an apartment somehow: not the one I had requested, and it was only half-loaded (textures missing). Real weird.



  • @meimeiriver It happened to me too. I disabled OAI, and the issue corrected itself. But I know it was because something wasn't jiving in one or both of the associated .INIs. I am starting to wonder though, if online maps isn't fully loading, because you are over budget on vRam consumption. If you are in the "yellow", then you are really in the "red", because the in-game settings can only account for the vRam according to the in-gamesettings, NOT all the extras you might have - higher resolution textures, car replacements, maps, etc...



  • @eshenk I was running SPA when I had 3,960 MB VRAM in use (of 4095) even. :) Now I even have a little less (3,755).

    I changed nothing, except to switch to 'Very high textures' and to install QuantV and an ENB. Changed textures back to 'high', but to no avail.

    Could be the config even. Still have Gameconfig for Patch 1.0.1011.1 Thing is, I don't think I even tried the apartment since March 17 (date of the last ScriptHook update).

    I appreciate your thoughts on the matter, though. :)



  • @meimeiriver Try disabling loading of MP maps in SPA .ini. What that does is only load MP maps when you try to enter an apartment.



  • @eshenk I had disabled SPA altogether already, and just tried to let Simple Trainer load the interior maps (which it can do). Immediate crash.

    Odd, I don't even seem to have an SPA.ini file.



  • @meimeiriver You do.It's in your SPA folder in your scripts folder. It's called setting.ini

    My config looks like this -

    //If you don't want to always Enable MP Maps, you can Turn this off.
    AlwaysEnableMPMaps "True"
    //If you have other mods that already loads MP Maps, your can turn this on.
    NeverEnableMPMaps "False"

    Also, I disabled several stilt-houses and a few low-end apartments, as it helped reduce some vRam consumption, alleviating some nasty pop-in as well.

    Also,if using OAI, you MUST disable online maps loading, or the conflict will cause strange anomalies.



  • @eshenk said in Apartments hosed?!:

    @meimeiriver You do.It's in your SPA folder in your scripts folder. It's called setting.ini

    My config looks like this -

    //If you don't want to always Enable MP Maps, you can Turn this off.
    AlwaysEnableMPMaps "True"
    //If you have other mods that already loads MP Maps, your can turn this on.
    NeverEnableMPMaps "False"

    Also, I disabled several stilt-houses and a few low-end apartments, as it helped reduce some vRam consumption, alleviating some nasty pop-in as well.

    Also,if using OAI, you MUST disable online maps loading, or the conflict will cause strange anomalies.

    Yeah, I had found the settings.cfg again. Made no difference.

    Like I said, though, even with SPA and OAI completely disabled (extensions renamed to .txt), even Simple Trainer immediately crashes on trying to load the interior.



  • @meimeiriver I don't use trainers, so I can't speak on that issue. It just came to me, why mine works and yours is problematic. I am using SPA BEFORE the lastest R* update. SPA needs to be upgraded to support latest scripthookv update I think, LOL. ImNotMental always updates his within a couple days of scripthookv update, FYI.



  • @meimeiriver Things get screwier by the minute, LOL. Disabled all MP map loading, both in SPA config and OAI.ini, and now Franklin's home looks like this (see below). Franklin's home is not an MP map, is it?!

    Eeek!



  • @meimeiriver THIS! Same thing happened to me. Here is what I remember:

    I used BOTH SPA and OAI in perfect harmony. When my PC went defunct last June, and I came back 8 months later, I couldn't remember exactly how I set the .inis to work together without conflict. It is because some of the lines in both .inis are a bit confusing, but there is the right setting/s for both that will make it work perfectly - I had done so before. bring both inis up side-by-side, and play with the options until you get it right - it WILL work.



  • @eshenk Also, there is another thread in this forrum talking about the same issue. @Cyron43 explained the issue a bit better than I. Something about disappearing beds, Franks car, etc.



  • @eshenk Here is how CYRON43 explained it -

    I had this happen once. The reason was an early version of ImNotMental's Single player apartment mod. it needs to switch to multiplayer map but all the single player items have to be respawned by the code because online dismisses them all in the first place. So, do you have any mod installed which uses the multiplayer map? If so then deactivate it and look if this solves your issue.
    Also, having multiple MP map mods activating the MP map is a bad idea but you can change that. For instance, I use Simple trainer, the Single player apartment mod and OpenAllInteriors. All of the 3 have the option to turn off the switch to MP map. Allow only ONE mod to do the switch. If that doesn't help, you found a fowl egg which doesn't respawn the SP items. In this case let another mod do the switch.



  • @eshenk The thing to keep in mind is, that all of this was working perfectly fine (including Franklin's home). It only got screwy because I just changed some settings, for the test. Hadn't touched those settings in ages before, and was always able to get to the apartments just fine.



  • @meimeiriver Make sure you read my reply above yours - it's just as cyron43 said, only ONE of the three must turn on MP maps, you have three things that can do that, SPA, OAI, and the trainer. If more than one of those are loading MP maps by default, it will cause your symptom.



  • @eshenk said in Apartments hosed?!:

    @meimeiriver Make sure you read my reply above yours - it's just as cyron43 said, only ONE of the three must turn on MP maps, you have three things that can do that, SPA, OAI, and the trainer. If more than one of those are loading MP maps by default, it will cause your symptom.

    I know this. :) But, like I said, my mods config hasn't changed in ages: there was always only 1 mod enabling the MP maps (Simple Trainer). And I was always able to access the interiors just fine. Reason why Franklin's apartment got fubarred, the other moment, is because I had set NeverEnableMPMaps to 'False' just now, and (contrary to what it suggests in the comment), it really just disables the MP maps.



  • @eshenk btw, these are always the last things OpenIV.log reports as having been loaded:

    10/04/2017 16:21:35.718 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/interiors/int_props/int_corporate.rpf'
    10/04/2017 16:21:35.718 [10664] TRACE: [fiPackfile::openArchive] 'dlcMPHeist:/x64/levels/gta5/_citye/sunset/ss1_11.rpf'
    10/04/2017 16:21:35.718 [10664] TRACE: [fiPackfile::openArchive] 'dlcMPHeist:/x64/levels/gta5/interiors/dlc_apart_high_new.rpf'
    10/04/2017 16:21:35.718 [10664] TRACE: [fiPackfile::openArchive] 'dlcMPHeist:/x64/levels/gta5/interiors/dlc_apart_high2_new.rpf'
    10/04/2017 16:21:35.718 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/interiors/int_props/int_medical.rpf'
    10/04/2017 16:21:35.718 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_citye/sunset/ss1_01.rpf'
    10/04/2017 16:21:35.718 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_citye/sunset/ss1_03.rpf'
    10/04/2017 16:21:35.718 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_citye/sunset/ss1_08.rpf'
    10/04/2017 16:21:35.718 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_citye/sunset/ss1_09.rpf'
    10/04/2017 16:21:35.718 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_citye/sunset/ss1_10.rpf'
    10/04/2017 16:21:35.718 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_citye/sunset/ss1_11.rpf'
    10/04/2017 16:21:35.719 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_hills/cityhills_02/ch2_07.rpf'
    10/04/2017 16:21:35.719 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_hills/cityhills_02/ch2_09.rpf'
    10/04/2017 16:21:35.719 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/interiors/v_int_64.rpf'
    10/04/2017 16:21:35.732 [10664] TRACE: [fiPackfile::openArchive] 'dlcMPHeist:/x64/levels/gta5/_citye/sunset/ss1_02.rpf'
    10/04/2017 16:21:35.744 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_hills/cityhills_02/ch2_12.rpf'
    10/04/2017 16:21:35.766 [10664] TRACE: [fiPackfile::openArchive] 'dlcMPHeist:/x64/levels/gta5/_hills/cityhills_02/ch2_07b.rpf'
    10/04/2017 16:21:35.766 [10664] TRACE: [fiPackfile::openArchive] 'dlcMPHeist:/x64/levels/gta5/_hills/cityhills_02/ch2_09b.rpf'
    10/04/2017 16:21:35.766 [10664] TRACE: [fiPackfile::openArchive] 'dlcMPHeist:/x64/levels/gta5/_hills/cityhills_02/ch2_09c.rpf'
    10/04/2017 16:21:35.778 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_cityw/beverly_01/bh1_42.rpf'
    10/04/2017 16:21:35.778 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_cityw/beverly_01/bh1_42b.rpf'
    10/04/2017 16:21:35.778 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_cityw/beverly_01/bh1_43.rpf'
    10/04/2017 16:21:35.778 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_cityw/beverly_01/bh1_45.rpf'
    10/04/2017 16:21:35.778 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_cityw/beverly_01/bh1_46.rpf'
    10/04/2017 16:21:35.778 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_cityw/beverly_01/bh1_46b.rpf'
    10/04/2017 16:21:35.778 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_cityw/beverly_01/bh1_48.rpf'
    10/04/2017 16:21:35.779 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_cityw/beverly_01/bh1_49.rpf'
    10/04/2017 16:21:35.779 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_cityw/beverly_01/bh1_49b.rpf'
    10/04/2017 16:21:35.779 [10664] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_cityw/beverly_01/bh1_rd.rpf'



  • @meimeiriver It will always show you the last files loaded based on where you are before you quit the game. For example I am usually out in the Countryside when I quit my game, so this is what my logs show -

    09/04/2017 12:34:20.099 [10168] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_hills/country_02/cs2_09.rpf'
    09/04/2017 12:34:26.339 [10168] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_hills/country_02/cs2_02.rpf'
    09/04/2017 12:34:30.597 [10168] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_hills/country_02/cs2_04.rpf'
    09/04/2017 12:34:38.632 [10168] TRACE: [fiPackfile::openArchive] 'dlcMPHeist:/x64/levels/gta5/_hills/country_02/cs2_05.rpf'
    09/04/2017 12:34:41.117 [10168] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_hills/country_02/cs2_railwyb.rpf'
    09/04/2017 12:34:45.219 [10168] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_hills/country_02/cs2_01.rpf'
    09/04/2017 12:35:07.247 [10168] TRACE: [fiPackfile::openArchive] 'dlcMPHeist:/x64/levels/gta5/_hills/country_02/country_02.rpf'
    09/04/2017 12:36:32.504 [10168] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_hills/country_02/cs2_06c.rpf'
    09/04/2017 12:36:35.882 [10168] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_hills/country_03/cs3_08g.rpf'
    09/04/2017 12:37:02.912 [10168] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_hills/country_03/cs3_03.rpf'
    09/04/2017 12:37:03.112 [10168] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_hills/country_03/cs3_08f.rpf'
    09/04/2017 12:37:03.243 [10168] TRACE: [fiPackfile::openArchive] 'platform:/levels/gta5/_hills/country_03/cs3_railway.rpf'
    09/04/2017 12:37:13.084 [10168] TRACE: [fiPackfile::openArchive] 'dlcMPHeist:/x64/levels/gta5/_hills/country_03/cs3_04.rpf'



  • @eshenk how you preventr trainers from being able to load mp maps ? i had OAI and MPmaps working fine without doing anything, then i needed to resintall and i'm having this problem, i can acess the main suite of majestic.



  • @BladeRJ You ONLY want SPA to load MP maps, turn off loading MP maps feature in both the trainer and OAI. Any conflicts between the three, and you will definitely have issues.



  • @eshenk said in Apartments hosed?!:

    @BladeRJ You ONLY want SPA to load MP maps, turn off loading MP maps feature in both the trainer and OAI. Any conflicts between the three, and you will definitely have issues.

    i asked how, i dont see such option in menyoo trainer ini. and the enhanced native trainer has no ini to configure,or you just mean dont use them in game ?


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.