@PlayZFakeYT first of all, you could post this in the help topic and no the one to request mods. second, what does it say when you try to start it? what version do you have installed? what mods do you have installed?