yeah, they need to update it as it doesn't work with the new updates